windows works, not linux

Saad Shakshir saads17 at hotmail.com
Fri Oct 1 15:46:07 EDT 2004


I installed the hostAP driver on a linux Fedora Core 2 box running kernel 
2.6.5.  The card I'm using is the Linksys WPC11 ver. 3.  I was stumped for a 
while because I couldn't connect to it from another linux box with the 
identical configuration.  I got a windows box and decided to just give it a 
shot and surprisingly, it detected the AP and connected with no problems.

here is the output of my iwconfig on the AP (master):

wifi0     IEEE 802.11b  ESSID:"linuxAP"  Nickname:"maximus"
          Mode:Master  Frequency:2.422GHz  Access Point: 00:06:25:2A:6D:B0
          Bit Rate:11Mb/s   Sensitivity=1/3
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:4606  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:546625   Missed beacon:0

wlan0     IEEE 802.11b  ESSID:"linuxAP"  Nickname:"maximus"
          Mode:Master  Frequency:2.422GHz  Access Point: 00:06:25:2A:6D:B0
          Bit Rate:11Mb/s   Sensitivity=1/3
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:4606  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:546625   Missed beacon:0

And here is the output of iwconfig on the client (managed):

wifi0     IEEE 802.11b  ESSID:"linuxAP"
          Mode:Managed  Frequency:2.437GHz  Access Point: 44:44:44:44:44:44
          Bit Rate:2Mb/s   Sensitivity=1/3
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:32/70  Signal level:-66 dBm  Noise level:-98 dBm
          Rx invalid nwid:0  Rx invalid crypt:8  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:478   Missed beacon:0

wlan0     IEEE 802.11b  ESSID:"linuxAP"
          Mode:Managed  Frequency:2.437GHz  Access Point: 44:44:44:44:44:44
          Bit Rate:2Mb/s   Sensitivity=1/3
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:32/70  Signal level:-66 dBm  Noise level:-98 dBm
          Rx invalid nwid:0  Rx invalid crypt:8  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:478   Missed beacon:0

I even tried to connect using the command:
iwconfig wlan0 ap 00:06:25:2A:6D:B0

It didn't return any error, but it didn't work either.  I would appreciate 
any input you might have.





More information about the HostAP mailing list