Compile hostap-driver 0.2.1

Jouni Malinen jkmaline at cc.hut.fi
Tue May 25 09:29:27 EDT 2004


On Tue, May 25, 2004 at 02:30:09PM +0200, Ulf Jakobsson wrote:

> I'm trying to compile the driver against the 2.4.19 kernel, but it 
> complains about the "list_move"
> 
> list_move(&bss->list, &local->bss_list);
> 
> in file:
> driver/modules/hostap_80211_rx.c
> 
> What should I do if I can't change kernel?

The development branch supports latest 2.4.x and 2.6.x kernels. 2.4.19
cannot really be called latest 2.4.x version.. You will either need to
add backwards conpatibility code for list_move or use Host AP driver
from the stable branch (0.1.x) which supports larger set of kernel
versions. Anyway, I would recommend updating the kernel if you are still
using 2.4.19..

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list