Senao SL2511 CD+ EXT2/Unresolved Symbols"depmod hostap_cs.o"

gaurav dawra openapproject at hotmail.com
Tue May 18 19:28:42 EDT 2004


Hi

Thankyou anywayz for your suggestions. i got the hostap-driver compiled and 
SORT OF working, as i am not sure it is working or not right now :)

After restarting "pcmcia service" , when i do "iwconfig", it gives me this 
warning: Please suggest what does that mean. Is it detected as a "device", 
now this is important for a project to understand how hostap driver handles 
the wireless card. What does wifi0 means, it is not detecting it as eth1 as 
eth0 is "ethernet" on my computer.
===============================================================================
[root at openap driver]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

dummy0    no wireless extensions.

sit0      no wireless extensions.

Warning: Driver for device wifi0 has been compiled with version 14
of Wireless Extension, while this program is using version 15.
Some things may be broken...

wifi0     IEEE 802.11-DS  ESSID:"test"
          Mode:Master
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
===============================================================================
please suggest what does that "warning means", as i first tried the 
hostap-driver-0.1.3 and then i even tried the hostap-driver-0.2.1 on it. 
Warning is still there. Please tell me will this wifi0 will work the same 
way as eth1 might have worked. If yes, why the wireless device is not listed 
in the REDHAT CONFIG NETWORK  wireless list.  Regarding that warning there 
seems to be not much documentation on the internet , not in FAQ.

Still Thanx for all your suggestions,  i will really appreciate if you can 
provide me some help or documentation to understand more about Hostap driver 
and wireless interface wifi0.

Regards,

Gaurav


>From: Pavel Roskin <proski at gnu.org>
>To: gaurav dawra <openapproject at hotmail.com>
>Subject: Re: Senao SL2511 CD+ EXT2/Unresolved Symbols"depmod hostap_cs.o"
>Date: Tue, 18 May 2004 17:54:54 -0400 (EDT)
>
>On Tue, 18 May 2004, gaurav dawra wrote:
>
>>I am sure that the PCMCIA support (CONFIG_PCMCIA) is disabled in the 
>>kernel. First of all i have downloaded the hostap-driver-0.1.3 and 
>>untarred in in "/home/hostap-0.1.3".
>>
>>I am using the vanilla kernel of redhat 2.4.20, which is in 
>>/usr/src/linux-2.4.20.
>>As suggested by you when i give the path to the PCMCIA_PATH and 
>>KERNEL_PATH in the "main" mail file in the directory /home/hostap-0.1.3, 
>>and do  the command make pccard, it gives me this error.
>>
>>Makefile:28: *** PCMCIA_PATH doesn't contain valid pcmcia-cs source.  
>>Stop.
>>---------------------------------------------------------------------
>>I looked into the make file line no. 28, it says this:  an ERROR message 
>>because it is looking for
>>ifeq (,$(wildcard $(PCMCIA_PATH)/include/pcmcia/version.h)),  please 
>>ignore my ignorance but i believe it means that it is checking the 
>>version.h file in the PCMCIA_PATH/include/pcmcia directory but there is no 
>>"include" directory. Please suggest why it is not taking the path i am 
>>entering into it. I also tried the command. The way i have entered the 
>>path is this way :
>>
>>PCMCIA_PATH=/home/hostap-driver-0.1.3
>
>I think it's wrong.  Please use separate directories for pcmcia-cs and 
>hostap.  PCMCIA_PATH should point to the directory where pcmcia-cs sources 
>are located.
>
>Just in case, the kernel should be in a separate directory too. KERNEL_PATH 
>should point to the kernel sources, not to the sources of pcmcia-cs or 
>hostap.
>
>>Also executed this command:
>>
>>make PCMCIA_PATH='/home/hostap-0.1.3' clean all, Still it didn't worked. 
>>The modules hostap_crypt.o and hostap_crypt_wep.o and hostap.o gets loaded 
>>but NOT hostap_cs.o , which when i look again into the /var/log/messages , 
>>lots of unresolved symbols. Also dmesg again says that "cardservices 
>>version mismatch"
>
>The error message in the makefile was correct.  Perhaps you have old 
>modules compiled with incorrect PCMCIA_PATH.  You may need to remove them 
>manually if the new driver doesn't overwrite them.
>
>>FYI i am using 2.4.20 kernel and senao NL2511CD+EXT2 card, ricoh based 
>>cards.
>>
>>Please suggest what i am doing wrong. Yes!! DO I HAVE TO MODIFIY THE 
>>Makefile in /hosap-driver-0.1.3/driver/modules to enter the 
>>PCMCIA_PATH(which it is not taking) in the starting.
>
>I believe you should not modify anything except the toplevel Makefile in 
>the hostap sources.
>
>--
>Regards,
>Pavel Roskin

_________________________________________________________________
MSN Toolbar provides one-click access to Hotmail from any Web page – FREE 
download! http://toolbar.msn.click-url.com/go/onm00200413ave/direct/01/




More information about the HostAP mailing list