Kernel panic using hostapd

Kwabbernoot kwabbernoot at
Sat May 15 06:02:04 EDT 2004

Hello all,

When I started to use hostapd (0.2.0) sometimes my kernel panics. 
The program on the stack is doing a NULL pointer deref. I have some 
photo's of my console taken with my camera. I have seen hotplug 
doing it a few times but sometimes it's an other program.

Today it looks like I can reproduce it. When my system starts up and 
ppp is trying to get a connection, hotplug is active. Today when I 
started hostapd on that moment and got three panics in a row. Two 
times hotplug and one time hostapd where causing it.

A month ago I tried the new CVS version and sinds then I didn't had 
this problem for a while. Today I set up WDS and tried to start 
hostapd automatically when my system started and I experienced it 
three times. I looks like it's related to the activity of hotplug at 
boottime but I'm not sure because this afternoon my kernel also 
paniced suddenly after running for a few hours.

I tried hostapd -dd but no output, so I tried a strace and the 
kernel paniced this moment:

open("/etc/hostapd.conf", O_RDONLY)     = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=8006, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, 
MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40014000
read(3, "##### hostapd configuration file"..., 4096) = 4096
read(3, "ADIUS packets. These are optiona"..., 4096) = 3910
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0x40014000, 4096)                = 0
ioctl(3, 0x8be0

Does somebody know if this is a known bug or maybe the solution?

More information about the HostAP mailing list