REDHAT 9.0/ pcmcia-cs Package/Ricoh Based Card Support

gaurav dawra openapproject at
Fri May 14 18:13:17 EDT 2004


I compiled hostap-0.0.4 and loaded these modules.

/etc/init.d/pcmcia restart
PCIC module not defined in startup options!

I recompiled the kernel and this message is coming. The CONFIG_PCMCIA is 
enabled in the .config file of my kernel. So is that a problem.

Here are the modules which i compiled and loaded using insmod:

[root at openap modules]# lsmod
Module                  Size  Used by    Not tainted
hostap_cs              42312   0  (unused)
hostap                 90820   0  [hostap_cs]

And also only these modules are being shown in lsmod command none other, 
also in the usr/src/linux-2.4.20rn/driver/pcmcia/ there is i82365.o module 
but when i do "insmod" on it , it prints this message on the screen.

[root at openap pcmcia]# insmod i82365.o
i82365.o: couldn't find the kernel version the module was compiled for"

I do not understand this as i just compiled my kernel using this source 

When i try to start the pcmcia service( I forgot to mention i am using 
2.4.20 kernel of RED HAT)
/etc/init.d/pcmcia restart
PCIC module not defined in startup options!

I tried to edit the /etc/sysconfig/pcmcia's PCIC option to i82365 , but as 
expected again gave me the same message when i tried to restart the PCMCIA 
service. Now i do not understand what is going wrong here. I believe i do 
not have the pcmcia-cs package installed successfully in my kernel.

DO i have to recompile my kernel with CONFIG_PCMCIA as NOT SET. And then 
download the pcmcia package from internet , if that is what i have to do 
which package is stable and i shud download?

Also how do i add the ds module in my kernel?, is there is some option in 
the configuration ".config" file that shud be enabled or disabled. Well the 
configuration file i am using has the PCMCIA SUPPORT SECTION loks like this:

# PCMCIA/CardBus support
# CONFIG_TCIC is not set
# CONFIG_I82092 is not set

Well when i look into this directory all i find is this:

[root at openap pcmcia]# pwd

[root at openap pcmcia]# ll
total 0
lrwxrwxrwx    1 root     root           45 May 14 03:08 aironet4500_cs.o -> 

please suggest what i am doing wrong. I believe that even the pcmcia package 
is not installed successfully in my kernel.

here is also the last three most recent lines of my "dmesg" command.

hostap_crypt: registered algorithm 'NULL'
hostap_crypt: registered algorithm 'WEP'
hostap_cs: 0.0.4 - 2003-07-27 (Jouni Malinen <jkmaline at>)

[root at openap modules]#



MSN Toolbar provides one-click access to Hotmail from any Web page – FREE 

More information about the HostAP mailing list