Please, help with the dwl520rev.E firmware!!!

Pavel Roskin proski at gnu.org
Wed May 12 02:06:19 EDT 2004


On Tue, 11 May 2004, Marcos Schonfeld wrote:

> I run lspci -xxxd 1260: for the different stages as you told me. The
> results were the same for the three cases, cold boot to Linux (failed to
> load the firmware), first reboot from windows to linux (success to load
> the firmware), and second reboot to linux (again success). Here is the
> lspci result:

The next thing to try is to dump the configuration space of all PCI
devices by "lspci -xxx" and compare them.  You also may want to compare
kernel logs and the contents of /proc/ioport and /proc/iomem.  It may
require some time and experience to separate important and unimportant
differences.  Look primarily for bridge resources.  Ignore changes in
bytes that change between successful boots.

Another thing to try is to enable CONFIG_ISA, CONFIG_PNP and
CONFIG_PNPBIOS is the kernel.  Use "lspnp -vvv" to see the resources used
by BIOS.  Check /proc/iomem to make sure those resources are not reused
for something else.  lspnp source is included with pcmcia-cs.

See if similar motherboards are listed in drivers/pci/quirks.c (Linux
source), but your motherboard is not.

This solved my problem with DWL-650 revision P - a PCMCIA card without
firmware in flash.

I know, digging this may be time consuming, but the potential reward is
more than just fixing support for one card.  It's fixing support for your
motherboard, which may fix things that never worked or didn't work
reliably (like ACPI).

Fixing motherboard problems would be offtopic here, so you may want to
post to LKML instead.  Feel free to write me privately about this.

-- 
Regards,
Pavel Roskin



More information about the HostAP mailing list