Cards seeming connect but unable to route traffic?

Christopher Dobbs crdobbs at eracew.net
Mon May 3 19:06:44 EDT 2004


Are you running hostapd.
Without it, some cards will conect, but wont route.

also try getting Bridge Utilities 
<http://www.eracew.net:/brtools/bridge-utils.tar.gz> and installing 
them.  Bridging the interfacew should work.
as a note, if you bridge, set the interfaces to promisc with the ip 0.0.0.0

ex:

ifconfig eth0 promisc 0.0.0.0 up
ifconfig wlan0 promisc 0.0.0.0 up
brctl addbr AP0
brctl addif AP0 eth0
brctl addif AP0 wlan0
ifcofig AP0 192.168.2.100

This example assumes that you are using 192.168.2.xx for your ip range.

Hope this helps.
Christopher Dobbs

Drew Dowling wrote:

>-----BEGIN PGP SIGNED MESSAGE-----
>Hash: SHA1
>
>
>I have a slackware box I decided to build into an AP.  I got a pair of
>ALLNET cards (ALL0192 - PCMCIA and  ALL0191 - PCI cause they were dirt
>cheap on ebay and seemed to be garenteed that I'd get a Prism2
>based card) an threw the PCI in to the slackware server and the PCMCIA
>into a IBM T30 with XP on it.
>
>I have a custom kernel, 2.6.4.  hostapd-0.1.3, wireless_tools.26
>built and seemingly woking.
>
>  
>
>>/sbin/ifconfig
>>    
>>
>eth0      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
>          inet addr:166.82.148.XX  Bcast:166.82.149.255 Mask:255.255.254.0
>          inet6 addr: xxxx::xxx:xxxx:xxxx:xxx/xx Scope:Link
>          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:37465 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:8601 errors:0 dropped:0 overruns:0 carrier:1
>          collisions:0 txqueuelen:1000 
>          RX bytes:12493046 (11.9 Mb)  TX bytes:942044 (919.9 Kb)
>          Interrupt:5 Base address:0xa400 
>
>eth0:0    Link encap:Ethernet  HWaddr 00:A0:24:9F:07:52  
>          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
>          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
>          Interrupt:5 Base address:0xa400 
>
>lo        Link encap:Local Loopback  
>          inet addr:127.0.0.1  Mask:255.0.0.0
>          inet6 addr: ::1/128 Scope:Host
>          UP LOOPBACK RUNNING  MTU:16436  Metric:1
>          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:0 
>          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
>
>wlan0     Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
>          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
>          inet6 addr: xxxx::xxx:xxxx:xxxx:xxxx/xx Scope:Link
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:0 errors:0 dropped:2 overruns:0 frame:0
>          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:1000 
>          RX bytes:0 (0.0 b)  TX bytes:1126 (1.0 Kb)
>          Interrupt:11 Memory:d0b18000-d0b19000 
>
>  
>
>>iwconfig
>>    
>>
>lo        no wireless extensions.
>
>dummy0    no wireless extensions.
>
>eth0      no wireless extensions.
>
>sit0      no wireless extensions.
>
>wlan0     IEEE 802.11b  ESSID:"drewhead_wap"  
>          Mode:Master  Frequency:2.412GHz  Access Point: XX:XX:XX:XX:XX:XX  
>          Bit Rate:11Mb/s   Sensitivity=1/3  
>          Retry min limit:8   RTS thr:off   Fragment thr:off
>          Encryption key:off
>          Power Management:off
>          Link Quality:0  Signal level:0  Noise level:0
>          Rx invalid nwid:0  Rx invalid crypt:230  Rx invalid frag:0
>          Tx excessive retries:7  Invalid misc:4   Missed beacon:0
>
>last relevant bit of dmesg:
>
>hostap_crypt: registered algorithm 'NULL'
>hostap_pci: 0.1.3 - 2004-02-08 (Jouni Malinen <jkmaline at cc.hut.fi>)
>hostap_pci: Registered netdevice wlan0
>prism2_hw_init: initialized in 184 ms
>wlan0: trying to read PDA from 0x007f0000: OK
>wlan0: NIC: id=0x8013 v1.0.0
>wlan0: PRI: id=0x15 v1.1.1
>wlan0: STA: id=0x1f v1.7.4
>wlan0: Intersil Prism2.5 PCI: mem=0xfb000000, irq=11
>wlan0: no IPv6 routers present
>
>Right now I'm just running wide open trying to get a connection
>established and packets routing.  I'll worry about locking things down when
>things are working.
>
>When I stick the PCMCIA card in the ThinkPad it finds the AP (by ESSID)
>and says it's connected.  I've given it a IP of 192.168.2.3, but pings
>timeout (the AP box does respond to ICMP on eth0).  Furthermore the AP
>seems to be able to find the laptop:
>
>  
>
>>iwlist scanning
>>    
>>
>lo        Interface doesn't support scanning : Operation not supported
>
>dummy0    Interface doesn't support scanning : Operation not supported
>
>eth0      Interface doesn't support scanning : Operation not supported
>
>sit0      Interface doesn't support scanning : Invalid argument
>
>wlan0     Scan completed :
>          Cell 01 - Address: XX:XX:XX:XX:XX:XX
>                    Mode:Managed
>                    Quality:15/92  Signal level:-20 dBm  Noise level:-39 dBm
>
>Where that XXed out MAC is the mac of the PCMCIA.  Furthermore dmsg
>spits out:
>wlan0: XX:XX:XX:XX:XX:XX auth_cb - frame was not ACKed
>wlan0: XX:XX:XX:XX:XX:XX auth_cb - STA authenticated
>wlan0: XX:XX:XX:XX:XX:XX assoc_cb - STA associated
>when I stick the card in the thinkpad and it successfully 'connects'.
>Again the XXs are the right MAC.
>
>This to me looks as if things are working good through the two
>interfaces... but I can't route packets?  What little simple things am I
>missing (it's got to be something simple right?)
>
>  
>
>>route
>>    
>>
>192.168.2.0     *               255.255.255.0   U     0      0        0 wlan0
>192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
>192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
>166.82.148.0    *               255.255.254.0   U     0      0        0 eth0
>loopback        *               255.0.0.0       U     0      0        0 lo
>default         XXXXXXXXXXXXXXX 0.0.0.0         UG    0      0        0 eth0
>
>- -- 
>     Drew Dowling               Drewhead          http://www.drewhead.org
> drewhead at drewhead.org    |                    |    WWW      / \ Alpha Phi Omega
>Concord, North Carolina   |                    |  Nimat     /   \  Gamma Lambda
>CLEMSON UNIVERSITY ALUMNI |                    | Apatschin /_____\
>      TIGER BAND!         |      VGAP4 Hosting at http://vgap.drewhead.org
>-----BEGIN PGP SIGNATURE-----
>Comment: Public key available at http://www.drewhead.org
>
>iD8DBQFAlsX48J7U7yHE638RAvoKAJ9jetVX6KDsVf3uVRWoUkCIclXDFQCfcg3N
>+jQfh0nTnJdGvtczVFb2ZSE=
>=DTUn
>-----END PGP SIGNATURE-----
>_______________________________________________
>HostAP mailing list
>HostAP at shmoo.com
>http://lists.shmoo.com/mailman/listinfo/hostap
>  
>

-- 
Christopher Dobbs
Eracew Computer Services
http://www.eracew.net/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20040503/1f11da2d/attachment.htm 


More information about the HostAP mailing list