firmware upgrade gone bad, looking for advice...

Jouni Malinen jkmaline at cc.hut.fi
Tue Mar 30 00:50:40 EST 2004


On Mon, Mar 29, 2004 at 09:27:21PM -0800, Casey Lewis wrote:

> hostap_pci: 0.1.3 - 2004-02-08 (Jouni Malinen <jkmaline at cc.hut.fi>)
> wlan0: NIC: id=0x8013 v1.0.0
> wlan0: PRI: id=0x15 v1.1.1
> Could not get RID for component STA
> wlan0: Failed to read STA f/w version - only Primary f/w present
> wlan0: Intersil Prism2.5 PCI: mem=0xf7bff000, irq=11
> wlan0: CMD=0x0001 => res=0x7f, resp0=0x0001
> wlan0: MAC port 0 enabling failed

Hmm.. I don't remember in which version I fixed some of the Primary-only
parts of the driver. Anyway, I would recommend trying the initialization
with a development version of the driver and prism2_srec (either 0.2.0
or CVS snapshot from development branch). Check whether the 'dmesg'
output from the initialization changes. The latest driver version is
supposed to be able to flash STA f/w on the card even if only the
Primary f/w is in working condition.

> When I try to flash the sta firmware using:
> # ./hostap-utils-0.1.3/prism2_srec -r -v wlan0 ./1.4.9/sf010409.hex

'-r' is RAM download, not flash (-f) download, although something else
went wrong with this because of the other error. Trying 0.2.0 version
should fix this, I think.

> ioctl[PRISM2_IOCTL_HOSTAPD]: No such device
> Missing wlan component info
> Could not read wlan RIDs
> 
> I'm assuming I get this because my system doesn't see that I have a 
> 'wlan0' since the card isn't loaded at boot.

dmesg output after prism2_srec could provide some useful information.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list