hostapd crash (due to unaligned access)

M. Grabert xam at cs.ucc.ie
Tue Mar 16 14:38:54 EST 2004


On Tue, 16 Mar 2004, M. Grabert wrote:

> > > You can set debug=3 and daemonize=0 in hostapd.conf and see frames dumps.
> > > Look at the frames with the first byte having bits 0 and 1 set.  You can
> > > post one to the list.
> >
> > Yes, it would be interesting to find out why this was happening, so full
> > debug dump of that frame would indeed be interesting.
>
> Will do that when I have time :-/

Unfortunately still no time to do that :(

> I only saw this problem everytime I use a wlan client, right after I the
> client tried to connect the hostapd access point (and then when
> connected, every couple of minutes), so it is definitely triggered by my
> wlan clients.

BTW, I forgot to mention (I actually forgot all about it) that I also
get the following messages every 2 minutes when a client is connected
to the hostapd:

Mar 15 23:34:52 beast kernel: wifi0: Could not find STA 00:01:00:09:5b:40
                                     for this TX error (@31184)
Mar 15 23:36:57 beast kernel: wifi0: Could not find STA 00:01:00:09:5b:40
                                     for this TX error (@43676)
Mar 15 23:39:02 beast kernel: wifi0: Could not find STA 00:01:00:09:5b:40
                                     for this TX error (@56181)

The strange thing is the STA MAC address, since it resembles somewhat the
MAC address of my hostapd (00:09:5B:40:B5:13)!
Seems like another padding/alignment problem ...


Hope that helps,
  Max


PS: so far the latest CVS version of hostapd seems to run stable, except
for creating those strange syslog messages ...



More information about the HostAP mailing list