hfa384x_get_rid problems.

Pavel Roskin proski at gnu.org
Fri Mar 12 21:59:14 EST 2004


On Sat, 13 Mar 2004, nettie wrote:

> Hi guys, I'm running gentoo 1.4 with vanilla kernel 2.6.3 and an Orinoco
> gold pcmcia card built-in in my laptop (kinda strange but it's a pmcica
> not a pci card). When I cardctl insert the "card" I stard getting a lot
> of errors, all of them related to hfa384x_get_rid.

HostAP doesn't work with Orinoco cards, although it can be fixed to
support them in managed and ad-hoc modes.

Orinoco cards are supported by Orinoco driver (managed and ad-hoc modes):
http://www.nongnu.org/orinoco/

If you want access point functionality, try HermesAP
(http://hunz.org/hermesap.html), but it needs updating for 2.6 kernels.

The Agere driver should also work, and it includes AP firmware:
http://www.agere.com/support/drivers/wl_lkm_714_release.tar.gz

-- 
Regards,
Pavel Roskin



More information about the HostAP mailing list