Linux based devices(intrinsyc cerf cubes) not communicating in ad hoc mode. Plz help

Srinivas Burugupalli srini208 at hotmail.com
Fri Jun 18 16:35:58 EDT 2004


 
I have configured two cubes A and B(based on 2.4 kernel) as wireless
devices. I used
hostap 0.0.4 drivers. And Netgear PCI cards. I also have a notebook
with a cisco card. All the three devices are configured in ad hoc
mode. What was wierd is, I could ping both A and B from my notebook,
A pings notebook, B pings notebook. Both A and B ping themselves but
unfortunately, A and B dont ping each other. A does not ping B and B
does not ping A. Thjis beats me. I dont know the reason. I used
ethereal ad saw that when notebook pings A, A answers the arp request
by notebook. When notebook pings B, B answers the arp request by note
book and gives a reply. But when A tries to ping B and B tried to
ping A, there is no arp reply from either A or B. I have no cluse as
to what is happening..

i have included the wlan0 iwconfig below.

Cube A:(device 1)

wlan0 IEEE 802.11b ESSID:"cube" Nickname:"romeo"
Mode:Ad-Hoc Frequency:2.462GHz Cell: 02:02:7F:E6:A5:EB
Sensitivity=1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0/92 Signal level:-100 dBm Noise level:-100
dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1268 Invalid misc:572 Missed
beacon:0

Cube B:(device 2)

wlan0 IEEE 802.11b ESSID:"cube" Nickname:"juliet"
Mode:Ad-Hoc Frequency:2.462GHz Cell: 02:02:43:DF:A5:F0
Sensitivity=1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0/92 Signal level:-100 dBm Noise level:-100
dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1515 Invalid misc:1358 Missed
beacon:0


I hope someone has an answer for this. I am totally clueless. Thank
you.

Thankign you in anticipation..
-Srinivas



More information about the HostAP mailing list