wpa_cli-0.2.4 problem

Jouni Malinen jkmaline at cc.hut.fi
Thu Jul 29 22:36:00 EDT 2004


On Sat, Jul 24, 2004 at 03:06:28PM +0200, Cristiano De Michele wrote:

> I installed yesterday wpa_supplicant-0.2.4 and I'm using it with  a
> USR805410 card + USR808054 AP and I noticed that from 0.2.3 to 0.2.4
> wpa_cli has stopped to work.

ctrl_interface location changed from v0.2.3 to v0.2.4. It is now a path
to a directory that will contain a socket file for the interface.

> Now if I do:
> > wpa_cli
> 
> I get following output
> 
> Could not connect to wpa_supplicant - re-trying

How did you configure ctrl_interface and ctrl_interface_group in
wpa_supplicant.conf? Does wpa_supplicant create the socket (e.g., what
does 'ls -l /var/run/wpa_supplicant' show)?

> >wpa_cli /var/run/wpa_supplicant
> Failed to connect to wpa_supplicant - wpa_ctrl_open: Not a directory

This is not a valid command line anymore.

> >wpa_cli -p /var/run/wpa_supplicant
> segmentation fault

That was a bug in 0.2.4. I fixed this now in CVS (both devel and 0.2
branch). In addition, the attached patch can be used to fix the 0.2.4
release (just one-line change).

-- 
Jouni Malinen                                            PGP id EFC895FA
-------------- next part --------------
Index: wpa_cli.c
===================================================================
RCS file: /home/jm/cvsroot/hostap/wpa_supplicant/wpa_cli.c,v
retrieving revision 1.20
diff -u -p -r1.20 wpa_cli.c
--- wpa_cli.c	18 Jul 2004 00:03:46 -0000	1.20
+++ wpa_cli.c	30 Jul 2004 02:25:50 -0000
@@ -620,7 +620,7 @@ int main(int argc, char *argv[])
 	int c;
 
 	for (;;) {
-		c = getopt(argc, argv, "hi:pv");
+		c = getopt(argc, argv, "hi:p:v");
 		if (c < 0)
 			break;
 		switch (c) {


More information about the HostAP mailing list