Killed dwl-650 when upgrading firmware

trooper ryan trooper_ryan at dmtsystems.net
Sat Jul 17 16:43:11 EDT 2004


Via winupdate.exe I was trying to upgrade my firmware from 1.5.6 to 
1.7.1 (s1010701.hex).  I encountered: "Error Programming Block. Continue 
anyway?" and chose not to continue.  Subsequently the card didnt 
function in windoze.

I've tried the same card under linux with no joy. I've posted my dmesg 
output below.  Any ideas if I can recover or if the card is fried?

Thanks.


cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x100-0x13f 0x170-0x177 
0x370-0x37f 0x4d0-0x4d7
cs: IO port probe 0x1000-0x17ff: clean.
cs: IO port probe 0x0a00-0x0aff: clean.
hostap_crypt: registered algorithm 'NULL'
hostap_cs: 0.1.3 - 2004-02-08 (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
hostap_cs: setting Vcc=33 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: index 0x01: Vcc 3.3, irq 9, io 0x0180-0x01bf
hostap_cs: Registered netdevice wlan0
wlan0: hfa384x_cmd - timeout - reg=0x8000
hostap_cs: first command failed - is the card compatible?
wlan0: hfa384x_cmd_issue: cmd reg was busy for 5000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c3f53d54, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: MAC port 0 enabling failed
wlan0: could not enable MAC port



More information about the HostAP mailing list