prism2_srec problem in 0.2.4 version

Pavel Roskin proski at gnu.org
Wed Jul 21 17:01:45 EDT 2004


On Wed, 21 Jul 2004, jar wrote:

> Brian Sturgill wrote:
>> 
>> You really should download a primary firmware along with it. Your 
>> primary firmware is ancient :)
>> 
>> Example: prism2_srec -r wlan0 ak010101.hex rf010800.hex

Not funny.  Somebody could actually try it and potentially damage the card 
(although prism2_srec is fairly safe in that regard).  In case you were 
not joking, please check if NIC ID 0x8002 is supported by the firmwares on 
the command line before advising to others.

> No this is "old" prism2 card not prism2.5 f-series card. Primary 
> firmaware is ok. What I want to say is, that when I used ver. 0.1.3 
> driver & utils I was able to download the ram firmaware to the card and 
> after that it initilizes & works ok. Now I have just updated the hostap 
> diver and utils to ver. 0.2.4. The same ram download doesn't seem to 
> work anymore for me. Maybe some firmware downloading related code has 
> changed?

Please provide more context both for the old and for the new driver.  Why 
do you need "-i"?  Did you upgrade the kernel together with hostap by any 
chance?  What's the version of the kernel?  Just in case, give information 
about the card (whether it's PCMCIA or PCI) and about the machine (non-x86 
architectures may get less testing).

-- 
Regards,
Pavel Roskin



More information about the HostAP mailing list