[PATCH] Signal, noise & quality values of clients - 0.1.3

Acinonyx Jubatus acinonyxs at yahoo.gr
Thu Jul 8 05:40:48 EDT 2004


I noticed a mismatch on the values of signal and silence in /proc/net/hostap/<if>/<client_mac> and the values listed by the iwlist <if> scan when working on master mode. 

This is what i get from /proc/net/hostap/<if>/<client_mac>:
...
buffer_count=0
last_rx: silence=165 signal=173 rate=20
tx_rate=110
...

signal and silence are ok. signal = 173 - 256 = -83dBm and silence = 165 - 256 = -91dBm which seem very normal.

...and this is what i get from iwlist <if> scan:

          Cell 01 - Address: XX:XX:XX:XX:XX:XX
                    Mode:Managed
                    Quality:229/92  Signal level:-32 dBm  Noise level:-34 dBm

Examining the code, i noticed that the values in the /proc/net/hostap/<if>/<client_mac> are in dBm, previously converted with HFA384X_RSSI_LEVEL_TO_dBm. But when they are retreived in order to get passed to wireless tools, they get converted again with HFA384X_LEVEL_TO_dBm. This is a bug because the values are already in dBm and they are mistakenly treated as if they were in the range 27-154. The same exists in quality update procedure so it must affect iwspy too. I attach a patch i made which fixes the problem with signal and noise levels. I also rewrote the link quality algorithmn to work with dBm values when scanning for associated clients. I've tested the patch on 1.7.4 and 1.3.6 F/W. I don't know if it works for 1.8.x. The card is a Netgear MA311.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20040708/637f1aad/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: hostap-driver-0.1.3-apscanfix-0.1.tar.gz
Type: application/x-gzip
Size: 679 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20040708/637f1aad/attachment.bin 


More information about the HostAP mailing list