WPA + ndiswrapper

Jouni Malinen jkmaline at cc.hut.fi
Mon Jul 5 20:32:06 EDT 2004


On Wed, Jun 30, 2004 at 01:57:05AM -0400, Giridhar Pemmasani wrote:

> I am trying to add WPA to ndiswrapper (http://ndiswrapper.sourceforge.net). 
> I have implemented all the necessary functionality that I think is
> needed for WPA, but, of course, "it doesn't work"! 

Are you changes available somewhere? Which NDIS driver are you using?

> I first tried to use wpa_supplicant 0.2.1, 0.2.2 and 0.2.3 and didn't
> make much progress, so decided to keep as simple as possible by
> borrowing wpa_supplicant from driverloader, as that is known to
> work.

I would highly recommend using the latest version of the code. I would
be interested in hearing if there are some differences between the old
version that that Linuxant used and the current CVS version that cause
problems for this kind of project.

> Right now, everything seems to work properly until setting
> tx_key. I believe wpa_supplicant expects an EAPOL message, which never
> arrives, so it gives up and a fresh scan is issued. I am wondering if
> you could shed some light into what could be the problem. I am
> attaching the output of wpa_supplicant below.

WPA starts with 4-Way Handshake with plaintext EAPOL messages. It looks
like you managed to complete this part successfully. The next step would
be to do Group Key Handshake, which begins with an encrypted EAPOL frame
from the AP. If you did not configure the pairwise key to the driver,
you would not see this message at all.

It would be useful to see wpa_ndiswrapper_set_key() implementation and
the matching handler in the ndiswrapper, to be able to tell what could
be going wrong..

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list