DWL 520 rev. E

Joshua Thorp joshua_thorp at myrealbox.com
Thu Jan 29 14:00:09 EST 2004




On Jan 28, 2004, at 11:38 PM, Jouni Malinen wrote:

> On Wed, Jan 28, 2004 at 01:14:33PM -0600, Joshua Thorp wrote:
>
>> modprobe hostap_pci
>> utils/prism2_srec -gs wlan0
>> ~joshua/Desktop/Downloads/primary/pm010102.hex
>> utils/prism2_srec -gp wlan0
>> ~joshua/Desktop/Downloads/primary/pm010102.hex
>> utils/prism2_srec  -rp wlan0
>> ~joshua/Desktop/Downloads/1.8.0/rf010800.hex
>
>> I now have a working card.
>
> Could you please send full 'dmesg' output from a successful
> initialization of the card? I would like to have something to compare
> failed downloads with.

Hi,

There are still a few bugs to work out on my end with the card as it 
turns out.  Yesterday I restarted my machine,  wasn't able to get the 
card to load,  at one point I managed to change the NIC to 0x8000 when 
it should be 0x8024.  So I turned off the computer and pulled the power 
cable and took PCI card out and put it back in.  When I rebooted 
everything went well.  This morning I thought perhaps the problem was 
because I didn't unload the driver properly before shutting down?

This morning I unloaded hostap_pci rebooted...everything worked as 
expected until I tried to contact another computer...  None were 
reachable.  I rebooted my access point,  a D-link DI-713P,  and 
everything is now working again.  I attatched my dmesg from this 
morning's adventure.  Yesterday I didn't get this line:

SIOCGIWAPLIST is currently only supported in Host AP mode

which is suspicious as I am not using WAP and am using HostAp in 
managed mode.  Oh I just realized where that line was probably coming 
from:  I was using wavemon and went to the aplist screen.



hostap_crypt: registered algorithm 'NULL'
hostap_pci: CVS (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_pci: Registered netdevice wifi0
wifi0: Original COR value: 0x21
hostap_pci: assuming no Primary image in flash - card initialization 
not completed
wifi0: test Genesis mode with HCR 0x1f
wifi0: Original COR value: 0x21
Readback test failed, HCR 0x1f write 00 e1 a1 ff read 00 ce a1 ce
wifi0: test Genesis mode with HCR 0x0f
wifi0: Original COR value: 0xa1
Readback test succeeded, HCR 0x0f
wifi0: Intersil Prism2.5 PCI: mem=0xfebfe000, irq=9
wifi0: registered netdevice wlan0
prism2_download: dl_cmd=4 start_addr=0x003f0000 num_areas=3
wifi0: test Genesis mode with HCR 0x0f
wifi0: Original COR value: 0x0
Readback test succeeded, HCR 0x0f
prism2_hw_init: initialized in 0 ms
wifi0: NIC: id=0x8000 v0.0.1
wifi0: PRI: id=0x15 v1.1.2
Could not get RID for component STA
wifi0: Failed to read STA f/w version - only Primary f/w present
prism2_download: dl_cmd=6 start_addr=0x003f0000 num_areas=3
wifi0: test Genesis mode with HCR 0x0f
wifi0: Original COR value: 0x0
Readback test succeeded, HCR 0x0f
prism2_hw_init: initialized in 0 ms
wifi0: NIC: id=0x8024 v1.0.0
wifi0: PRI: id=0x15 v1.1.2
Could not get RID for component STA
wifi0: Failed to read STA f/w version - only Primary f/w present
prism2_download: dl_cmd=5 start_addr=0x003f0c01 num_areas=3
prism2_hw_init: initialized in 30 ms
wifi0: NIC: id=0x8024 v1.0.0
wifi0: PRI: id=0x15 v1.1.2
wifi0: STA: id=0x1f v1.8.0
prism2: wlan0: operating mode changed 3 -> 2
wifi0: LinkStatus=1 (Connected)
wifi0: LinkStatus: BSSID=00:05:5d:ec:f2:f4
SIOCGIWAPLIST is currently only supported in Host AP mode
SIOCGIWAPLIST is currently only supported in Host AP mode
SIOCGIWAPLIST is currently only supported in Host AP mode

... cut long list of repeated error ...

SIOCGIWAPLIST is currently only supported in Host AP mode
SIOCGIWAPLIST is currently only supported in Host AP mode
SIOCGIWAPLIST is currently only supported in Host AP mode

... then I logged onto the internet ...

ip_tables: (C) 2000-2002 Netfilter core team
ip_conntrack version 2.1 (1023 buckets, 8184 max) - 292 bytes per 
conntrack
CSLIP: code copyright 1989 Regents of the University of California
PPP generic driver version 2.4.2
PPP BSD Compression module registered
PPP Deflate Compression module registered


wifi0: Original COR value: 0x6d

... couldn't contact my laptop so tried to reload module,  card RAM ...

hostap_pci: Driver unloaded
hostap_pci: CVS (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_pci: Registered netdevice wifi0
wifi0: Original COR value: 0x21
hostap_pci: assuming no Primary image in flash - card initialization 
not completed
wifi0: test Genesis mode with HCR 0x1f
wifi0: Original COR value: 0x21
Readback test failed, HCR 0x1f write 00 e1 a1 ff read 00 ce a1 ce
wifi0: test Genesis mode with HCR 0x0f
wifi0: Original COR value: 0xa1
Readback test succeeded, HCR 0x0f
wifi0: Intersil Prism2.5 PCI: mem=0xfebfe000, irq=9
wifi0: registered netdevice wlan0
prism2_download: dl_cmd=4 start_addr=0x003f0000 num_areas=3
wifi0: test Genesis mode with HCR 0x0f
wifi0: Original COR value: 0x0
Readback test succeeded, HCR 0x0f
prism2_hw_init: initialized in 0 ms
wifi0: NIC: id=0x8000 v0.0.1
wifi0: PRI: id=0x15 v1.1.2
Could not get RID for component STA
wifi0: Failed to read STA f/w version - only Primary f/w present
prism2_download: dl_cmd=6 start_addr=0x003f0000 num_areas=3
wifi0: test Genesis mode with HCR 0x0f
wifi0: Original COR value: 0x0
Readback test succeeded, HCR 0x0f
prism2_hw_init: initialized in 0 ms
wifi0: NIC: id=0x8024 v1.0.0
wifi0: PRI: id=0x15 v1.1.2
Could not get RID for component STA
wifi0: Failed to read STA f/w version - only Primary f/w present
prism2_download: dl_cmd=5 start_addr=0x003f0c01 num_areas=3
prism2_hw_init: initialized in 30 ms
wifi0: NIC: id=0x8024 v1.0.0
wifi0: PRI: id=0x15 v1.1.2
wifi0: STA: id=0x1f v1.8.0

...changed to managed mode,  still couldn't contact laptop ...

prism2: wlan0: operating mode changed 3 -> 2
wifi0: LinkStatus=1 (Connected)
wifi0: LinkStatus: BSSID=00:05:5d:ec:f2:f4

..then I rebooted the accesspoint

wifi0: LinkStatus=4 (Access point out of range)
wifi0: LinkStatus: BSSID=00:05:5d:ec:f2:f4
wifi0: LinkStatus=5 (Access point in range)
wifi0: LinkStatus: BSSID=00:05:5d:ec:f2:f4
wifi0: LinkStatus=2 (Disconnected)
wifi0: LinkStatus: BSSID=00:05:5d:ec:f2:f4
wifi0: LinkStatus=1 (Connected)
wifi0: LinkStatus: BSSID=00:05:5d:ec:f2:f4

and it works.

Attatched please find my full dmesg if you are interested.

--Joshua

-------------- next part --------------
A non-text attachment was scrubbed...
Name: dmesg_012804.gz
Type: application/x-gzip
Size: 3531 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20040129/6afa3584/attachment.bin 
-------------- next part --------------


> -- 
> Jouni Malinen                                            PGP id 
> EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>
>
>


More information about the HostAP mailing list