DWL 520 E1 (the continuing saga)

Andrew Barr barr.156 at osu.edu
Wed Jan 28 19:53:36 EST 2004


My best guess is that the firmware you are using is the issue. There are
more qualified people on this list than I who can confirm or refute that.
Try the firmware here: http://www.red-bean.com/~proski/firmware/.

Andrew

> -----Original Message-----
> From: hostap-bounces+barr.156=osu.edu at shmoo.com 
> [mailto:hostap-bounces+barr.156=osu.edu at shmoo.com] On Behalf 
> Of cliffo at u.washington.edu
> Sent: Wednesday, January 28, 2004 7:08 PM
> To: hostap at shmoo.com
> Subject: DWL 520 E1 (the continuing saga)
> 
> First off, many thanks to Pavel and Andrew for their 
> explanations of getting the E1 revision of this card to work. 
>  I've been following this lengthy thread trying to get mine 
> up and running...I'm 70% there.
> 
> I'm using the latest version from CVS (downloaded today) and 
> using prism2_srec included in that update.  prism2_srec is 
> failing on the second firmware update for the card and I'm 
> perplexed as to my next step.
> 
> Here are the commands I ran followed by dmesg output:
> 
> [~]# modprobe hostap_pci
> <snipped from dmesg>
> Readback test succeeded, HCR 0x0f
> wifi0: Intersil Prism2.5 PCI: mem=0xd4000000, irq=12
> wifi0: registered netdevice wlan0
> 
> [~]# ./utils/prism2_srec -gs wlan0 ~cliff/firmware/pm010102.hex
> <from dmesg> 
> prism2_download: dl_cmd=4 start_addr=0x003f0000 num_areas=3
> wifi0: test Genesis mode with HCR 0x0f
> wifi0: Original COR value: 0x0
> Readback test succeeded, HCR 0x0f
> prism2_hw_init: initialized in 0 ms
> wifi0: valid PDA not found
> wifi0: NIC: id=0x8000 v0.0.1
> wifi0: PRI: id=0x15 v1.1.2
> Could not get RID for component STA
> wifi0: Failed to read STA f/w version - only Primary f/w present
> 
> ...and here is where I really have troubles...I verified that 
> PRISM2_DOWNLOAD_SUPPORT is defined in driver/module/hostap_config.h
> 
> [~]# ./utils/prism2_srec -gp wlan0 ~cliff/firmware/pm010102.hex
> <output from prism2_srec>
> srec summary for pm010102.hex
> Included file name: PM010102.HEX
> Component: 0x0015 1.1.2 (primary firmware)
> 
> ioctl[PRISM2_IOCTL_HOSTAPD]: No data available
> STAID not available (maybe running PRI-only)
> ioctl[PRISM2_IOCTL_HOSTAPD]: No data available
> ioctl[PRISM2_IOCTL_HOSTAPD]: No data available
> Could not read wlan PDA. This requires 
> PRISM2_DOWNLOAD_SUPPORT definition in
> driver/module/hostap_config.h.
> 
> <from dmesg>
> Could not get RID for component STA
> wifi0: Failed to read STA f/w version - only Primary f/w present
> 
> So that is where I'm at and not sure where to go next.  I've 
> also tried ak10104.hex as someone suggested with no luck.  
> TIA for your feedback...
> 
> Cliff
> 
> 
> 
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
> 




More information about the HostAP mailing list