D-link DWL-520 not 520+

Erick Del Orbe derickito at hotmail.com
Tue Jan 20 23:41:33 EST 2004

Well thanks a lot all of you,

  The revision I have is D, it seems I have to go w/ the Realtek drivers, 
the funny thing is that when I looked at the windows driver files they were 


that may or may not mean anything, but the fact is that the Realtek drivers 
actually load, the problem I'm having w/ that driver is setting it's 
parameters like channel an oprate(1mps,5mps,11mps).  When I use iwpriv to 
set it, it doesn't give me an error, but it doesn't change.  I also tried 
iwconfig wlan0 commit and they still didn't change.  I can change the SSID, 
but that's the only change that'll show up in /proc. Oh well thank you for 
the confirmation at least I don't have to keep trying the hostap driver.

P.S. - I don't know if this is the proper way to reply so that'll showup on 
the mailing list let me know if I did something wrong.

>From: James B Hiller <jhiller at visi.net>
>To: Andrew Barr <barr.156 at osu.edu>
>CC: derickito at hotmail.com, hostap at shmoo.com
>Subject: RE: D-link DWL-520 not 520+
>Date: Tue, 20 Jan 2004 22:03:20 -0500 (EST)
>Hi.  See comments embedded below.
>On Tue, 20 Jan 2004, Andrew Barr wrote:
> > The success stories you are reading about, at least the recent ones, 
>have to
> > do with revision E of this card, which is a firmwareless Prism2.5-based
>Correct.  However, in the Jun 03 timeframe when I began my hostap quest,
>I found on this list, and using the linux-wlan-ng site, that DWL 520 in
>Rev A1 and B1 were reported to be functional with hostap, as those two
>revs used the Prism 2.5 (actually, I think that included A2 and maybe
>B2 as well, if such things existed - check the linux-wlan-ng site for
>clarity on this point).
>The rev of the card makes all the difference as to whether what Andrew
>says applies or what I say applies, so you need to check that (by
>inspection - the only sure way).
>In Jul and Aug, I secured what turned out to be one of each Rev A1 and B1
>of the card, and have used them both since with hostap, since its version
>0.0.4.  I did take care to flash firmware on both cards past what they
>were delivered with (like 1.3.4), based on reports in this list of a
>packet loss problem with any version < 1.3.6.  I believe I witnessed
>that problem prior to the flash.  Since the flash (am running STA 1.7.4
>with PRI 1.1.1), they run like champs.
>[snip rest of Andrew's text; all correct from what I've seen)
> > > a PC card). I've tried the hostap drivers(hostap_pci,
> > > hostap_plx) and they say no device found. I've read else
>Don't bother with plx; no use there.  You may be experiencing issues
>in compilation or module loading.  I don't have the very latest
>hostap, but there were some glitches with recent kernels and recent
>hostap versions.  Am going from memory since I'm away from my box,
>but believe you have to do like make hostap, rather than make
>hostap_pci.  If you still have issues this weekend, hit me off-list
>and I'll try to help.
> > > where success stories about the 520 using the hostap driver,
> > > but I believe they were talking about the 520+, which (I
> > > believe) is different.  So, my question is, has anyone here
>Any stories about the 520+ would only have been with the kernel
>driver for it that's being developed, and not hostap, as the 520+
>uses a TI chipset, acx1100, I believe.  The site for that driver
>is acx1100.sf.net (if I got the nomenclature right).
> > > gotten the DWL-520 (not the520+) working with the hostap
> > > drivers or any others. Thanx for your help.
>As above - I have it working with both hostap and with the Prism
>driver included in the linux kernel.  I have one card in service
>as an AP, the other as a basic client, but have used both in both
> > > P.S. - The D-Link website points me to the RealTek website
> > > when I look for linux drivers.  Specifically the rtl8180_24x
> > > driver. This driver loads w/ no problem and I see wlan0, but
> > > I can't get an ip (dhcp).
> > > I have not tried loading this driver at boot time, does
> > > anyone know the parameters to pass to it at boot time?
>As Andrew pointed out, this would only be useful for the later
>revs of the card, IF that's what you're dealing with.

Check out the coupons and bargains on MSN Offers! 

More information about the HostAP mailing list