Problem with NetGear MA311 (Prism2.5) and hostap

John Shaw jshaw at gtphitau.org
Wed Jan 21 21:52:44 EST 2004


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I recently purchased a NetGear MA311 PCI card to use with my desktop
machine because I knew it had a Prism 2.5 chip on it and I had every
indication they were well supported by linux.  I am running a 2.6.1
kernel and I was using the orinoco_pci driver built into the kernel
everything appear to work fine.  That is to say everything worked fine
until somebody started downloading a file off my machine and my
connection died.  I did several tests and found this always happened
whenever I was transmitting data.

So then I read about the hostap driver.  I build and installed the
newest stable driver and loaded it up.  All appeared ok, card was
detected, I got an IP from the AP.  So I go to download a file with my
and it is actually working, but then I notice my desktop has 100% CPU
utilization and is barely responsive.  Download finishes, thing is
responsive again.  Repeat, same thing happens. So I did a dmesg and I
saw a bunch of errors from soft_irq.  I have attached them to this file.

Anyone have any idea what is wrong or how I might go about fixing it.
It would be nice to be able to transmit and receive with my wireless PCI
card.

BTW, I have a Pentium III 550Mhz. with 768MB of RAM that the card is in,
which I figure should be plenty fast enough if it weren't printing debug
statements out of the kernel at a mile per minutes.

Thanks,

John Shaw
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQFADzr8yRYiVjZar8ERAutJAKDAixYRWEMUMuMYKg9qwSuaRkSIKACgpfxG
MeQDB2C+ZkT7UYCit7YwgnU=
=Slgj
-----END PGP SIGNATURE-----
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: WIRELESSINFO
Url: http://lists.shmoo.com/pipermail/hostap/attachments/20040121/636b0454/attachment.txt 


More information about the HostAP mailing list