Problems installing hostap on SuSE 9.0?

Mark G. Spencer mspencer at evidentdata.com
Wed Jan 21 13:06:03 EST 2004


Today I made another run at getting hostap running on my Gateway 200 ARC notebook
with a SMC2532W-B (Prism 2.5 chipset) PC Card.  I'm running SuSE 9.0 with the 
latest updates.

I used the SuSE rpm for hostap, which is hostap version 0.0.4-98.  After installing
the rpm, I rebooted and checked the dmesg output.  prism2_cs was still being
used, no mention of hostap.  Searching the filesystem for hostap*, I can see hostap 
files have been distributed in a variety of locations by the rpm.

The hostap docs mention that the hostap_cs.conf file should be in /etc/pcmcia.
I noticed after my rpm was installed, the hostap_cs.conf file was in 
/usr/src/kernel-modules/hostap-0.0.4/driver/etc.  I moved the file over to 
/etc/pcmcia and rebooted.  No dice.  The SMC2532W-B manuf id is listed in the 
hostap_cs.conf file, so that's not the problem.

I kept digging and updated the /etc/pcmcia entries in wlan-ng.conf to reflect a
binding to hostap_cs for the entry that matched my cardctl ident.  Didn't work.  
I then updated the /etc/pcmcia/config file to reflect a binding to hostap_cs for my
cardctl ident output, still didn't work.  I have since removed the wlan-ng.conf
from /etc/pcmcia, leaving /etc/pcmcia/config and /etc/pcmcia/hostap_cs.conf.  

If I run "modprobe hostap_cs" I see:

hostap_crypt: registered algorithm 'NULL'
hostap_cs: 0.0.4 - 2003-07-27 (Jouni Malinen <jmaline at cc.hut.fi>)

I'm not sure what I need to do here .. pcmcia_cs still loads on bootup.  I'm not a
Linux guru, so I think its very possible (likely!) I'm missing something that is
obvious to other listmembers.  I've read through the hostap docs and just finished 
reading through the PCMCIA HOWTO.

Thanks for the advice,

Mark




More information about the HostAP mailing list