DWL-650 rev P - no progress with CVS hostap..

Pavel Roskin proski at gnu.org
Sat Feb 28 22:57:17 EST 2004


On Sat, 28 Feb 2004, Joshua Kwan wrote:

> On Sat, Feb 28, 2004 at 10:18:00PM -0500, Pavel Roskin wrote:
> > > But the card does work flawlessly in Windows. Could I somehow flash it
> > > there with something special to make it usable in Linux?
> >
> > You cannot flash it because the flash is very short - it can only hold the
> > PDA and the CIS.
> >
> > If the card works in Windows on the same machine, it's very encouraging
> > because it shows that the problem is in hardware, not in software.
>
> Did you mean software, not hardware? That's quite reassuring...

Sorry, of course I meant software.  But you are still unclear if Windows
was on the same machine or not.  I'm assuming it was.

My best guess at the moment is that we are not initializing something that
often has a reasonable value, but not on certain hardware.  In other
words, we are relying on "undefined" values being correct.  I've seen it
with sound cards.  Maybe filling the card RAM with zeroes would help, or
something like that.

> > The workaround it to use a different PCMCIA bridge, such as plx9052 based
> > one (such as Linksys WDT11), which worked on that "bad" machine where TI
> > and Ricoh bridges didn't work.
>
> Don't think I have the balls to excise the PCMCIA bridge from my laptop
> and put in a new one ;)
>
> PS. Email sucks, interested in joining me at Freenode/#hostap?

I prefer to write something that remains archived for others.  Also I
prefer to have time to check facts and make some research, and I expect
the same from others.

-- 
Regards,
Pavel Roskin



More information about the HostAP mailing list