Problems compiling hostap-driver for kernel 2.6.3

Pavel Roskin proski at gnu.org
Mon Feb 23 15:39:51 EST 2004


On Mon, 23 Feb 2004, Julian Finn wrote:

> now it worked, but I have the following problem:
> hyperion:~/hostap-driver-0.2.0# modprobe hostap_pci
> WARNING: Error inserting hostap
> (/lib/modules/2.6.3/kernel/drivers/net/wireless/hostap.ko): Invalid
> module format
> FATAL: Error inserting hostap_pci
> (/lib/modules/2.6.3/kernel/drivers/net/wireless/hostap_pci.ko): Invalid
> module format

You may have obsolete or incorrectly installed module-init-tools.  Get and
install the latest version 3.0-pre10 from
http://www.kernel.org/pub/linux/kernel/people/rusty/modules/

Run depmod to see if the module dependencies are OK.

> What am I doing wrong?

You are not giving enough information.  If a program gives an error
message you don't expect, there is a high probability that the program is
wrong.  If you don't give its version, other people have to guess
something that is trivial for you to find.

-- 
Regards,
Pavel Roskin



More information about the HostAP mailing list