Problems compiling hostap-driver for kernel 2.6.3

Julian Finn julian at echoes-online.de
Sun Feb 22 16:42:39 EST 2004


> > >Anyway: after "make install", modprobe hostap_pci brings up:
> > >FATAL: Module hostap_pci not found.
> > >I believe this is because kernel 2.6 doesn't call its modules .o
> > >anymore, right? Well, I just find for example "hostap_pci.o" in
> > >/lib/modules/2.6.3/net
> 
> Hmm.. That's odd. When I run "make install" for Host AP driver, the
> modules are installed into
> /lib/modules/2.6.3/kernel/drivers/net/wireless directory and they are
> the correct (*.ko) versions. Is your KERNEL_PATH (by default,
> /usr/src/linux) pointing to the correct kernel source tree?
My Makefile has KERNEL_PATH=/usr/src/linux-2.6.3 which is correct.


> Could you please verify that the hostap_pci.o file was added by "make
> install" in Host AP tree by first removing that object file and running
> "make install" again? What is the output of following command?
> 
> find /lib/modules/2.6.3 -name 'hostap*'
> 
> Please also send full output of running "make" and "make install" for
> the Host AP driver.

output of make: 


Makefile:38: WARNING: No kernel PCMCIA support found and PCMCIA_PATH is
not defined
make -C /usr/src/linux-2.6.3
SUBDIRS=/root/hostap-driver-0.2.0/driver/modules \
        MODVERDIR=/root/hostap-driver-0.2.0/driver/modules modules
	make[1]: Entering directory `/usr/src/linux-2.6.3'
	*** Warning: Overriding SUBDIRS on the command line can cause
	***          inconsistencies
	make[2]: `arch/i386/kernel/asm-offsets.s' is up to date.
	  CC [M]  /root/hostap-driver-0.2.0/driver/modules/hostap.o
	    CC [M]
	    /root/hostap-driver-0.2.0/driver/modules/hostap_crypt_wep.o
	      CC [M]
	      /root/hostap-driver-0.2.0/driver/modules/hostap_crypt_tkip.o
	        CC [M]
		/root/hostap-driver-0.2.0/driver/modules/hostap_crypt_ccmp.o
		  CC [M]
		  /root/hostap-driver-0.2.0/driver/modules/hostap_cs.o
		    CC [M]
		    /root/hostap-driver-0.2.0/driver/modules/hostap_plx.o
		      CC [M]
		      /root/hostap-driver-0.2.0/driver/modules/hostap_pci.o
		        Building modules, stage 2.
			  MODPOST
			    CC
			    /root/hostap-driver-0.2.0/driver/modules/hostap.mod.o
			      LD [M]
			      /root/hostap-driver-0.2.0/driver/modules/hostap.ko
			        CC
				/root/hostap-driver-0.2.0/driver/modules/hostap_crypt_ccmp.mod.o
				  LD [M]
				  /root/hostap-driver-0.2.0/driver/modules/hostap_crypt_ccmp.ko
				    CC
				    /root/hostap-driver-0.2.0/driver/modules/hostap_crypt_tkip.mod.o
				      LD [M]
				      /root/hostap-driver-0.2.0/driver/modules/hostap_crypt_tkip.ko
				        CC
					/root/hostap-driver-0.2.0/driver/modules/hostap_crypt_wep.mod.o
					  LD [M]
					  /root/hostap-driver-0.2.0/driver/modules/hostap_crypt_wep.ko
					    CC
					    /root/hostap-driver-0.2.0/driver/modules/hostap_cs.mod.o
					      LD [M]
					      /root/hostap-driver-0.2.0/driver/modules/hostap_cs.ko
					        CC
						/root/hostap-driver-0.2.0/driver/modules/hostap_pci.mod.o
						  LD [M]
						  /root/hostap-driver-0.2.0/driver/modules/hostap_pci.ko
						    CC
						    /root/hostap-driver-0.2.0/driver/modules/hostap_plx.mod.o
						      LD [M]
						      /root/hostap-driver-0.2.0/driver/modules/hostap_plx.ko
						      make[1]: Leaving
						      directory
						      `/usr/src/linux-2.6.3'
						      make
						      install_all_info
						      make[1]: Entering
						      directory
						      `/root/hostap-driver-0.2.0'
						      Makefile:38:
						      WARNING: No kernel
						      PCMCIA support
						      found and
						      PCMCIA_PATH is not
						      defined
						      *** Become
						      superuser and
						      'make install' to
						      install the
						      modules. ***
						      make[1]: Leaving
						      directory
						      `/root/hostap-driver-0.2.0'
make install doesn't work at the moment. it brings up: 
Makefile:38: WARNING: No kernel PCMCIA support found and PCMCIA_PATH is
not defined
Installing /etc/pcmcia/hostap_cs.conf
cp: cannot create regular file `/etc/pcmcia/hostap_cs.conf': No such
file or directory
make: *** [install_conf] Error 1

i believe the .o - files were copied when I tried make install_pci. 


any idea how I can run a normal make install? 

And: will copying th .ko - files to the right dir work? 

Cheers, 

Julian



						      



> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap



More information about the HostAP mailing list