wpa_supplicant and XSupplicant

Jonny Karlsson IT 00 karlssoj at arcada.fi
Wed Feb 18 09:27:39 EST 2004


Hello!

Does anyone know what versions of the xsupplicant software are patchable
with the xsupplicant.path or are pre-patched with wpa support together
with the wpa_supplicant? I have tried xsupplicant 0.8 and 0.8b but but
both gives error messages when I'm trying to patch with the xsupplicant
patch. I get the following error when patching:

--------------------------------------------------------------------
[root at test-radius xsupplicant]# cat xsupplicant.patch | patch -p0
patching file src/eap.c
Hunk #1 FAILED at 88.
Hunk #2 FAILED at 172.
Hunk #3 FAILED at 268.
3 out of 3 hunks FAILED -- saving rejects to file src/eap.c.rej
can't find file to patch at input line 86
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: src/xsup_driver.c
|===================================================================
|RCS file: /home/jm/cvsroot/xsupplicant/src/xsup_driver.c,v
|retrieving revision 1.1.1.1
|retrieving revision 1.2
|diff -u -p -r1.1.1.1 -r1.2
|--- src/xsup_driver.c  29 Nov 2003 00:49:36 -0000      1.1.1.1
|+++ src/xsup_driver.c  29 Nov 2003 00:56:02 -0000      1.2
--------------------------
File to patch:

--------------------------------------------------------------------

Or am I patching somehow in the wrong way? I've seen a similar problem in
the mailing list but those instructions couldn't give me any help.


Regards

Jonny Karlsson



More information about the HostAP mailing list