hostap_cs: RequestIRQ: Resource in use

Thorsten Giese tg at unixag-zw.fh-kl.de
Sat Feb 7 12:02:12 EST 2004


Hello.

I am using kernel 2.6.2 and since 2.6.1 I have some strange Problem. I 
searched the Mailinglist-archives, but did not find a solution.

I use hostap-cvs at the moment, but also tried the regular, stable release

hostap_crypt: unregistered algorithm 'NULL' (deinit)
hostap_crypt: registered algorithm 'NULL'
hostap_cs: CVS (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
hostap_cs: setting Vcc=33 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: Registered netdevice wifi0
hostap_cs: RequestIRQ: Resource in use
prism2_config() failed



hostapd tells me

coruscant hostap # /etc/init.d/hostapd restart
 * Bringing wlan0 up...
SIOCSIFADDR: No such device
wlan0: unknown interface: No such device
SIOCSIFBRDADDR: No such device
wlan0: unknown interface: No such device
SIOCSIFNETMASK: No such device
 * Failed to bring wlan0 up                                                 
[ !! ]

 * Starting HostAPD...
Configuration file: /etc/hostapd/hostapd.conf
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: No such device
Could not enable hostapd mode for interface wlan0
ioctl[SIOCGIFFLAGS]: No such device
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: No such device
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: No such device                            
[ !! ]



-- 
regards
Thorsten



More information about the HostAP mailing list