ipw2100 + WPA-PSK link dies if not used

Andrew Barr barr.156 at osu.edu
Sat Dec 25 22:51:51 EST 2004

On Sat, 2004-12-25 at 16:12, Szymon Juraszczyk wrote:
>    Hi everyone,
>    I successfully made use of my ipw2100 and connected my notebook to a 
> D-Link AP using WPA-PSK. However, I've noticed a wierd behaviour, namely 
> when the link is not used for a while (a few idle minutes is enough), it 
> simply stops working. Wpa_supplicant with -d shows no errors (haven't 
> tried more -d's though...), but no packet can be sent.
>    After some testing I realised that sending pings (to my AP, ruter or 
> wherever else) every second helps to keep the link alive. Otherwise it 
> would stop working if not used for a while and I would have to restart 
> wpa_supplicant to get it working back again.
>    My software is:
> 	- Debian sarge+sid (mixed using APT::Default-Release "testing")
> 	- 'self-made' kernel 2.6.10 (also tried 2.6.10-rc3 before)
> 	- ipw2100 open source driver v1.0.2 (tried 1.0.1 as well) with
> 	  ipw2100-1.0.2-set_security.patch
> 	- wpa_supplicant v 0.3.2-1 (Debian's package from sid, tried
> 	  0.2.5-2 from sarge as well)
>    The hardware is IBM ThinkPad T41 with built in IPW2100 and D-Link DI-514.
>    Here is my /etc/wpasupplicant.conf:
> ctrl_interface=/var/run/wpa_supplicant
> ctrl_interface_group=0
> eapol_version=2
> ap_scan=1
> network={
>          ssid="mynetworkssid"
>          proto=WPA RSN
>          key_mgmt=WPA-PSK
>          pairwise=CCMP TKIP
>          group=CCMP TKIP WEP104 WEP40
>          psk="myverysecretpassphrase"
>          priority=2
> }
>    Although running the ping in the background is not a problem, I'd 
> like to try to investigate the issue, possibly helping to improve the 
> code. Any clues?

Could this be bug #245 in the ipw2100 driver:
http://www.bughost.org/bugzilla/show_bug.cgi?id=245 ? I have a very
similar problem with a WPA-Enterprise setup.


More information about the HostAP mailing list