Corrupted Prism2 Card

Peter peter at peter.dyndns.info
Thu Dec 16 12:18:03 EST 2004


Am Donnerstag, den 16.12.2004, 08:24 -0800 schrieb Lawrence Wong:
> Hi all,
> 
> I was trying to upgrade my LinkSys WMP11 PCI wireless
> card using the hostap utils and it seems like I
> corrupted the Primary Firmware. I am wondering if
> anyone has encountered this problem before or knows
> how to fix it.
> 
> Before upgrading, everything is working fine and dmesg
> shows the following when the hostap & hostap_pci
> modules are loaded:
> 
> 
> hostap_pci: Registered netdevice wifi0
> wifi0: Original COR value: 0x0
> prism2_hw_init: initialized in 195 ms
> wifi0: NIC: id=0x8013 v1.0.0
> wifi0: PRI: id=0x15 v1.1.0
> wifi0: STA: id=0x1f v1.8.0
> wifi0: Intersil Prism2.5 PCI: mem=0xeb400000, irq=10
> wifi0: registered netdevice wlan0
> 
> 
> During upgrading, the following is shown on dmesg:
> 
> 
> prism2_download: dl_cmd=3 start_addr=0x00000000
> num_areas=3
> Download buffer: 4096 bytes at 0x0060:0x0000
> prism2_hw_init: initialized in 85 ms
> wifi0: starting flash download
> prism2_hw_init: initialized in 2 ms
> wifi0: NIC: id=0x8013 v1.0.0
> wifi0: PRI: id=0x15 v1.1.1
> Could not get RID for component STA
> wifi0: Failed to read STA f/w version - only Primary
> f/w present
> wifi0: Card initialized successfully after flash
> download
> wifi0: CMD=0x0002 => res=0x7f, resp0=0x0001
> 
> 
> After the upgrading is over, I tried to activate the
> wireless interface and the following is shown:
> 
> 
> wifi0: NIC: id=0x8013 v1.0.0
> wifi0: PRI: id=0x15 v1.1.1
> Could not get RID for component STA
> wifi0: Failed to read STA f/w version - only Primary
> f/w present
> wifi0: Intersil Prism2.5 PCI: mem=0xeb400000, irq=10
> wifi0: registered netdevice wlan0
> wlan0: CMD=0x0001 => res=0x7f, resp0=0x0001
> wlan0: MAC port 0 enabling failed
> wlan0: could not enable MAC port
> 
> 
> I am no longer able to access the wireless interface.
> hostap_diag also does not work.
> 
> 
> ./hostap_diag wlan0
> Host AP driver diagnostics information for 'wlan0'
> 
> ioctl[PRISM2_IOCTL_HOSTAPD]: No such device
> Could not communicate with the kernel driver.
> 
> 
> I used the following commandline to upgrade the
> Primary Firmware and prism_srec did not complain of
> any incompatibilities (it said OK) when I ran it
> without the "-f" parameter.
> 
> ./prism2_srec -f wlan0 ak010104.hex
> 

this is the firmware image for download to ram,
you should have downloaded the p....hex file
(see e.g. http://linux.junsun.net/intersil-prism/ )

which version of hostap/hostap-utils are you running?
i thought i read some time ago that this shouldn't be possible
any more..


> 
> Can anyone help me out in this or is my card off to
> heaven?


if you get the hostap module to detect your card:
see the "hostap_fw_load" script in the hostap-utils package on how
to load the firmware for cards with no primary image

else:
...

> 
> TIA!
> 
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around 
> http://mail.yahoo.com 
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap


regards,
peter



More information about the HostAP mailing list