WPA_PTK entering state AUTHENTICATION2

Project 2k4 prj2004 at web.de
Fri Dec 10 09:05:23 EST 2004


Friends,

I've been trying to get hostapd working with 3 different PCMCIA cards 
(Windows-XP SP2 supplicant), but something doesn't work each time and I 
have not been successful with any of them. Problems appearing are:

* With a stock 802.11b driver (Senao NL-2511CD Plus Mercury) driver I
   got the error:

    -----
    STA 11:02:6e:34:9a:e4: No WPA/RSN IE in association request
    -----

   which sounds like a problem w/ the driver of the PC-Card, even though
   I have been using the Win-XP supplicant.

   No worries, I had other cards to try...;)

* With a Cisco Aironet 350 (ACU: 6.3.011, Driver: 8.6.16.0), I get
   output such as below, and then no further progress in
   authentication:

    -----
    mgmt::reassoc_req
    reassociation request: STA=00:07:50:cb:1b:fa capab_info=0x11 
listen_interval=200
    current_ap=00:02:6f:34:97:d4
    new AID 1
    wlan0: STA 00:07:50:cb:1b:fa IEEE 802.11: association OK (aid 1)
    MGMT (TX callback) ACK
    mgmt::reassoc_resp cb
    wlan0: STA 00:07:50:cb:1b:fa IEEE 802.11: associated (aid 1)
    wlan0: STA 00:07:50:cb:1b:fa WPA: event 1 notification
    wlan0: STA 00:07:50:cb:1b:fa WPA: start authentication
    WPA: 00:07:50:cb:1b:fa WPA_PTK entering state INITIALIZE
    WPA: 00:07:50:cb:1b:fa WPA_PTK_GROUP entering state IDLE
    WPA: 00:07:50:cb:1b:fa WPA_PTK entering state AUTHENTICATION
    WPA: 00:07:50:cb:1b:fa WPA_PTK entering state AUTHENTICATION2
    -----

Has anyone seen the auth fail at "WPA_PTK entering state 
AUTHENTICATION2"? Is this a symptom of something I should check? Any 
hints would help.

TIA
Jonnas



-- 
http://www.confero24.com
The Best Source of Network Hardware for Open Source Projects



More information about the HostAP mailing list