iwconfig trouble

capacity77 at tin.it capacity77 at tin.it
Mon Dec 6 06:56:07 EST 2004


Hi Brian!
yes, I'm going to use this machine as an AP but there are a couple of things
that make me guess that the configuration is not perfect, would you help
me,please?

You know that I was using the linux-wlan-ng driver for my Compaq WL100 (it
was working well!) but I had to remove it to use hostap. I just edited the
/etc/modules.conf file commenting the line loading the module. Then I installed
hostap and it opened another interface called wifi0 and now with iwconfig
i see that I have 2 interfaces set on the same device, the wlan0 and the
wifi0:

iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wifi0     IEEE 802.11b  ESSID:"test"
          Mode:Master  Frequency:2.422 GHz  Access Point: 00:50:8B:99:B7:FF
          Bit Rate:11 Mb/s   Sensitivity=1/3
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:70  Invalid misc:33   Missed beacon:0

wlan0     IEEE 802.11b  ESSID:"test"
          Mode:Master  Frequency:2.422 GHz  Access Point: 00:50:8B:99:B7:FF
          Bit Rate:11 Mb/s   Sensitivity=1/3
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:70  Invalid misc:33   Missed beacon:0

You can see wifi0 and wlan0 look at the same device.
Is it ok if I leave the 2 interfaces or I have to remove one? Which is the
hostap file controlling wifi0? 
Then there's another thing: the led on the wireless card is blinking, it
should mean that the card is not configured properly! And as a matter of
facts, other machines don't see me at all with iwlist scan! :((

Save our souls!
Dom




>-- Messaggio originale --
>From: "Brian Sturgill" <zen_hacker at hotmail.com>
>To: capacity77 at tin.it
>Subject: Re: iwconfig trouble
>Date: Sun, 05 Dec 2004 18:55:16 +0000
>
>
>Now ... Are you going to use this machine as an access point or as a client
>
>to an access point? Your hardware has been detected. The card comes up
by
>
>default in Master mode (Ie access point mode). If you want this... go ahead
>
>and use ifconfig to set an IP address to it. (example:  ifconfig wlan0

>192.168.1.10 netmask 255.255.255.0) Then set the ssid to whatever you want
> 
>example : iwconfig wlan0 essid test
>
>If you are going to use it as a client, use the iwconfig command to change
>
>the card to client mode. example:  iwconfig wlan0 mode managed essid test
>
>(assuming the ssid of the access point is test) You can then set the ip

>address of the card using ifconfig wlan0. You can also set the ip using
a
>
>dhcp server on the same subnet using dhclient.
>
>Hope this info helps. It seems you are well on your way to mking it work.
>
>Brian
>
>>From: capacity77 at tin.it
>>To: "Brian Sturgill" <zen_hacker at hotmail.com>
>>Subject: Re: iwconfig trouble
>>Date: Sun, 5 Dec 2004 19:15:09 +0100
>>
>>so what exactly should I do?
>>I edited the modules.conf, removing the lines that lead to the old driver,
>>is it enough? Now when I insert the card, the hostap and hostap_cs modules
>>get loaded and a wifi0 interface appear but it doesn't seem work (the
led
>>of the card is not fixed). the dmesg gived this messages:
>>
>>hostap_cs: 0.2.5  -  2004-10-03 (Jouni Malinen <jkmaline at cc.hut.fi>)
>>hostap_cs: setting Vcc=33 (constant)
>>hostap_cs: CS_EVENT_CARD_INSERTION
>>hostap_cs: setting Vcc=33 (from config)
>>Checking CFTABLE_ 0x01 (default 0x01)
>>IO window setting: cfg->io.nwin=1 dftl.io.nwin=1
>>io->flags = 0x0046, io.base=0x0000, len=64
>>hostap_cs: Registered netdevice wifi0
>>hostap_cs: index 0x01: Vcc 3.3, irq 5, 0x0100-0x013f
>>prism2_hw_init: initialized in 100 ms
>>wifi0: NIC: id=0x8002 v1.0.1
>>wifi0: PRI: id=0x15 v0.3.0
>>wifi0: STA: id=0xaf v0.8.0
>>wifi0: defaulting for host-based encryption as a workaround for firmware
>>bug in Host AP mode WEP
>>wifi0: defaulting to bogus WDS frame as a workaround for firmware bug
in
>>Host AP mode WDS
>>using data:: nullfunc ACK workaround - firmware upgrade recommended
>>wifi0: registered netdevice wlan0
>>
>>any hint for me? How can I configure my netdevice?
>>Dom
>>
>>
>>
>> >-- Messaggio originale --
>> >From: "Brian Sturgill" <zen_hacker at hotmail.com>
>> >To: capacity77 at tin.it
>> >Subject: Re: iwconfig trouble
>> >Date: Sat, 04 Dec 2004 11:51:01 +0000
>> >
>> >
>> >Right... Hostap driver can work in managed, adhoc and Hostap mode with
>>no
>> >
>> >probs. Managed is a client to an access point. Master mode is Hostap

>>mode.
>> >
>> >This mode makes the card act as a access point (beacon and management
>> >frames) Just make sure you disable wlan-ng driver and just use Hostap.
>>I
>> >can
>> >act as a client, and an access point really easily. Everything you need
>>is
>> >
>> >right there if you have a Prism2/2.5/3 card.
>> >
>> >>From: capacity77 at tin.it
>> >>To: "gaurav dawra" <openapproject at hotmail.com>
>> >>CC: hostap at shmoo.com
>> >>Subject: Re: iwconfig trouble
>> >>Date: Sat, 4 Dec 2004 09:57:40 +0100
>> >>
>> >>
>> >>So to make HostAP work, I don't need any other driver, such as orinoco,
>> >>right?
>> >>
>> >>
>> >> >-- Messaggio originale --
>> >> >From: "gaurav dawra" <openapproject at hotmail.com>
>> >> >To: capacity77 at tin.it
>> >> >Cc: hostap at shmoo.com
>> >> >Subject: Re: iwconfig trouble
>> >> >Date: Fri, 03 Dec 2004 21:27:46 +0000
>> >> >
>> >> >
>> >> >Hostap is a Driver. I configured Compaq card with orinoco driver

>>earlier.
>> >> >It
>> >> >works great.
>> >> >
>> >> >--Gaurav
>> >> >
>> >> >>From: capacity77 at tin.it
>> >> >>To: "gaurav dawra" <openapproject at hotmail.com>
>> >> >>Subject: Re: iwconfig trouble
>> >> >>Date: Thu, 2 Dec 2004 19:01:09 +0100
>> >> >>
>> >> >>the Compaq WL 100 DOES HAVE an Intersil Prism chipset, hostap should
>> >
>> >>work
>> >> >>with with it.
>> >> >>Now I have a quiestion: hostap IS the driver for the AP mode or
it
>>can
>> >>also
>> >> >>be the driver of the wireless card? I mean, does hostap need that
>the
>> >>card
>> >> >>works with another driver or is provides also this function?
>> >> >>
>> >> >>
>> >> >>
>> >> >> >-- Messaggio originale --
>> >> >> >From: "gaurav dawra" <openapproject at hotmail.com>
>> >> >> >To: capacity77 at tin.it
>> >> >> >Subject: Re: iwconfig trouble
>> >> >> >Date: Thu, 02 Dec 2004 17:44:41 +0000
>> >> >> >
>> >> >> >
>> >> >> >
>> >> >> >You can't set both of them. Host AP driver works with Prism 2/2.5
>>
>> >>cards
>> >> >>and
>> >> >> >
>> >> >> >if i remember correctly compaq card works with orinocco driver.
>I
>>
>> >>tried
>> >> >>to
>> >> >> >
>> >> >> >run compaq card with hostap driver. It detects but parameters

>>cannot
>> >>be
>> >> >>set
>> >> >> >
>> >> >> >cooreclty, it was expected. The card service is a deamon which

>>loads
>> >>and
>> >> >> >
>> >> >> >unloads any drivers by doing hot swapping.
>> >> >> >
>> >> >> >There is a distinction, if you want to use hostap it works only
>
>>with
>> >>
>> >> >>Prism
>> >> >> >
>> >> >> >2/2.5 chipset. Change card and get cards like Netgear Ma401, Senao
>> >
>> >>NL2511
>> >> >> >
>> >> >> >CDplus.
>> >> >> >
>> >> >> >Thanx.
>> >> >> >--Gaurav
>> >> >> >>From: capacity77 at tin.it
>> >> >> >>To: "Derek Chan" <dwc+hostap at OCF.Berkeley.EDU>
>> >> >> >>CC: hostap at shmoo.com
>> >> >> >>Subject: Re: iwconfig trouble
>> >> >> >>Date: Thu, 2 Dec 2004 18:33:36 +0100
>> >> >> >>
>> >> >> >>why can't I? the linux-wlan-ng is the driver for my wireless
card,
>> >>to
>> >> >>use
>> >> >> >>hostap i have to use necessarily also a driver for the card.
>> >> >> >>I have a Compaq WL 100, I need the linux-wlan-ng driver. Or maybe
>> >is
>> >> >
>> >> >>there
>> >> >> >>any other simpler driver for Prism2 cards as mine?
>> >> >> >>
>> >> >> >>
>> >> >> >>
>> >> >> >> >-- Messaggio originale --
>> >> >> >> >Date: Thu, 2 Dec 2004 09:24:01 -0800
>> >> >> >> >From: Derek Chan <dwc+hostap at OCF.Berkeley.EDU>
>> >> >> >> >To: capacity77 at tin.it
>> >> >> >> >Cc: Josh Wyatt <jdwyatt at joshua.raleigh.nc.us>, hostap at shmoo.com
>> >> >> >> >Subject: Re: iwconfig trouble
>> >> >> >> >
>> >> >> >> >
>> >> >> >> >On Thu, Dec 02, 2004 at 06:00:25PM +0100, capacity77 at tin.it

>>wrote:
>> >> >> >> >> my Compaq WL100 is not an usb device is a wireless lan pcmcia
>> >
>> >>card
>> >> >>
>> >> >> >>(based
>> >> >> >> >> on Intersil Prism chipset). But you surprised me cos when
I
>> >> >>installed
>> >> >> >>the
>> >> >> >> >> linux-wlan-ng driver, in the modules.conf there's something
>>that
>> >> >> >>reminds
>> >> >> >> >> an usb device rather than a wireless card!
>> >> >> >> >> Anyway
>> >> >> >> >>
>> >> >> >> >> lsmod says:
>> >> >> >> >> Module                  Size  Used by    Not tainted
>> >> >> >> >> prism2_cs              98420   0
>> >> >> >> >> p80211                 37348   0  [prism2_cs]
>> >> >> >> >
>> >> >> >> >Unload the linux-wlan-ng drivers before you load the hostap
>> >>drivers.
>> >> >> >> >You can't use both at once.
>> >> >> >> >
>> >> >> >> > - Derek
>> >> >> >> >
>> >> >> >> >--
>> >> >> >> >Be the change you want to see in the world
>> >> >> >> >        -- Mahatma Gandhi
>> >> >> >>
>> >> >> >>
>> >> >> >>_______________________________________________
>> >> >> >>HostAP mailing list
>> >> >> >>HostAP at shmoo.com
>> >> >> >>http://lists.shmoo.com/mailman/listinfo/hostap
>> >> >> >
>> >> >> >_________________________________________________________________
>> >> >> >Express yourself instantly with MSN Messenger! Download today
-
>
>>it's
>> >>
>> >> >>FREE!
>> >> >> >
>> >> >> >http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/
>> >> >> >
>> >> >>
>> >> >>
>> >> >
>> >> >_________________________________________________________________
>> >> >Don?t just search. Find. Check out the new MSN Search!
>> >> >http://search.msn.click-url.com/go/onm00200636ave/direct/01/
>> >> >
>> >>
>> >>
>> >>_______________________________________________
>> >>HostAP mailing list
>> >>HostAP at shmoo.com
>> >>http://lists.shmoo.com/mailman/listinfo/hostap
>> >
>> >
>>
>>
>
>





More information about the HostAP mailing list