flashing-problem

Steffen Schwientek schwientek at web.de
Wed Aug 25 14:57:48 EDT 2004


On Wednesday 25 August 2004 14:47, Jouni Malinen wrote:
> On Wed, Aug 25, 2004 at 01:40:18AM +0000, Steffen Schwientek wrote:

>
> Which prism2_srec command did you use? 
 
prism2_srec  wifi0  sf010800.hex
I have also tried the -g,r, and f switch, all time the same error.
I also tried other firmware, no chance.

> What version of the driver and 
> prism2_srec are you using?

both actual cvs.

> What does 'ls -R /proc/net/hostap' show? ls -R /proc/net/hostap

/proc/net/hostap:
wlan0

/proc/net/hostap/wlan0:
ap  ap_control  ap_debug  aux_dump  bss_list  crypt  debug  pda  scan_results  
stats  wds


> What  
> does 'dmesg' show after this attempt (including the driver
> initialization)?

Ähm, I think nothing,if the driver is loaded. If I insert the card (PCMCIA), 
dmesg reports the following. ls -R /proc/net/hostap adds nothung more to 
dmesg output.

hostap_crypt: registered algorithm 'NULL'
hostap_cs: CVS (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
hostap_cs: setting Vcc=50 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: Registered netdevice wifi0
hostap_cs: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f
prism2_hw_init: initialized in 4 ms
wifi0: NIC: id=0x801b v1.0.0
wifi0: PRI: id=0x15 v1.1.1
Could not get RID for component STA
wifi0: Failed to read STA f/w version - only Primary f/w present
wifi0: registered netdevice wlan0
prism2: wlan0: operating mode changed 3 -> 2
wlan0: CMD=0x0121 => res=0x7f, resp0=0x0004
wlan0: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=127, rid=fc00, len=2)
wlan0: CMD=0x0121 => res=0x7f, resp0=0x0004
wlan0: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=127, rid=fc0e, 
len=34)
wlan0: CMD=0x0121 => res=0x7f, resp0=0x0004
wlan0: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=127, rid=fc02, 
len=34)
wlan0: CMD=0x0001 => res=0x7f, resp0=0x0001
wlan0: MAC port 0 enabling failed
wlan0: could not enable MAC port

Steffen



More information about the HostAP mailing list