Problems making WPA work with ndiswrapper/broadcom

Donald Teed dteed at
Sat Aug 14 12:33:41 EDT 2004

On Sat, 14 Aug 2004, Jouni Malinen wrote:

> On Fri, Aug 13, 2004 at 06:58:53PM -0300, Donald Teed wrote:
>> network={
>>         eap=MSCHAPV2
>>         phase1="auth=MSCHAPV2"
>> }
> Those should be
>    eap=PEAP
>    phase2="auth=MSCHAPV2"
> for EAP-PEAP with MSCHAPv2 as the inner auth.

Thanks for the assistance - much appreciated...

That second phase1 was a typo - but thanks for pointing it out.
I had tried PEAP before as well, but something I read
in the docs suggested that MSCHAPV2 would work.

I've fixed these things.  But this probably isn't the
problem area right now, as you say.

> If this happens even with the interface up, please verify whether AP
> scan works when triggered manually with "iwlist <ifname> scan".

I'm in Slackware 9.  So I've done ifconfig wlan0 up
and the "Network is down" message goes away.  The current
trace is pretty much the same to my eye:

EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Setting scan request: 0 sec 100000 usec
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=6):
      61 63 61 64 69 61                                 acadia
Failed to initiate AP scan.


When I run 'iwlist wlan0 scan' I get back

wlan0     No scan results

So perhaps it can't work if the SSID isn't being broadcast
by the access point.

>> The documentation is not clear on how iwconfig and iwpriv
>> should be used.  I've done what seems to be reasonable
>> in attempting to set a channel for iwconfig and so on.
> No iwconfig/iwpriv commands should be required for this.

So wpa_supplicant can work with any channel automatically?

>> The driver ndiswrapper will show the MAC from ifconfig wlan0
>> so I think we have a good driver.  The broadcom chipset
>> is said to be supported, so I don't know what is wrong.
> This may depend on which NDIS driver you are using. I have successfully
> tested ndiswrapper with Broadcom chipset.

I'm using:

ndiswrapper -l
Installed ndis drivers:
bcmwl5  hardware present
bcmwl5a hardware present

lspci -v , lspci -n:

02:03.0 Network controller: Broadcom Corporation: Unknown device 4320 (rev 03)
         Subsystem: Dell Computer Corporation: Unknown device 0003
         Flags: bus master, fast devsel, latency 32, IRQ 7
         Memory at fafee000 (32-bit, non-prefetchable) [size=8K]

02:03.0 Class 0280: 14e4:4320 (rev 03)

>> Will this work if the AP isn't broadcasting the SSID?
> I don't remember whether this was implemented in ndiswrapper. Anyway,
> the debug log you sent did not yet get this far..

Here is some more stuff from /proc which seems to
indicate the traffic is happening:

cat /proc/net/wireless
Inter-| sta-|   Quality        |   Discarded packets               | Missed | WE
  face | tus | link level noise |  nwid  crypt   frag  retry   misc | beacon | 16
  wlan0: 0000  100   246     0        0      0      0      0 9376827        0

Likewise in iwconfig:

wlan0     IEEE 802.11g  ESSID:off/any
           Mode:Managed  Frequency:2.437GHz  Access Point: 00:00:00:00:00:00
           Bit Rate:54Mb/s   Tx-Power:25 dBm
           RTS thr:2347 B   Fragment thr:2346 B
           Encryption key:off
           Power Management:off
           Link Quality:100/0  Signal level:-10 dBm  Noise level:-256 dBm
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:0  Invalid misc:9393190   Missed beacon:0

If there are more suggestions, I'll be eager to try them out.

More information about the HostAP mailing list