Intersil Prism Javelin MINIPCI module 1260:3886 (quite long)

nettie nettie at apple2.com
Tue Aug 3 14:15:29 EDT 2004


Hi guys,

I just aquired a bounce of Intersil/Connexant Prism Javelin MINIPCI 
adapters.

The monolithic kernel I was running on my sbc was already patched and 
compiled with hostap drivers.

The first problem I figured out is that the minipci module was not 
detected my the driver, after checking out hostap_pci.c I realized that 
the pci id of the module was not present. I added it and 
recompiled/installed the kernel.

During boot time the module has been detected but I started having some 
problems:

hostap_pci: 0.2.3 - 2004-06-20 (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_pci: Registered netdevice wifi0
wifi0: Original COR value: 0x4e
hostap_pci: assuming no Primary image in flash - card initialization not 
completed
wifi0: test Genesis mode with HCR 0x1f
wifi0: Original COR value: 0x4e
Readback test failed, HCR 0x1f write 00 e1 a1 ff read ce fa ce fa
wifi0: test Genesis mode with HCR 0x0f
wifi0: Original COR value: 0x4e
Readback test failed, HCR 0x0f write 00 e1 a1 ff read ce fa ce fa
wifi0: Intersil Prism2.5 PCI: mem=0x80000000, irq=12
wifi0: registered netdevice wlan0

------------

When I tried to access the wlan0 interface I got the following errors:

wifi0: cannot get RID fdc6 (len=12) - no PRI f/w
wifi0: cannot get RID fdc6 (len=12) - no PRI f/w
wifi0: cannot get RID fdc1 (len=2) - no PRI f/w
wifi0: cannot get RID fc06 (len=2) - no PRI f/w
wifi0: cannot get RID fd42 (len=6) - no PRI f/w
wifi0: cannot get RID fc0e (len=34) - no PRI f/w
wifi0: cannot get RID fc84 (len=2) - no PRI f/w
wifi0: cannot get RID fc83 (len=2) - no PRI f/w
wifi0: cannot get RID fc82 (len=2) - no PRI f/w
wifi0: cannot get RID fc09 (len=2) - no PRI f/w
wifi0: cannot get RID fd48 (len=2) - no PRI f/w


------------

[root at airbox /tmp]# /stuff/iwconfig
lo        no wireless extensions.

teql0     no wireless extensions.

eth0      no wireless extensions.

wifi0     IEEE 802.11-DS  ESSID:"test"
           Mode:Master
           Encryption key:off
           Link Quality:0  Signal level:0  Noise level:0
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wlan0     IEEE 802.11-DS  ESSID:"test"
           Mode:Master
           Encryption key:off
           Link Quality:0  Signal level:0  Noise level:0
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:0  Invalid misc:0   Missed beacon:0

tunl0     no wireless extensions.

gre0      no wireless extensions.

ipsec0    no wireless extensions.

ipsec1    no wireless extensions.

ipsec2    no wireless extensions.

ipsec3    no wireless extensions.


---------------

[root at airbox /tmp]# ifconfig wlan0 10.0.0.1 netmask 255.255.255.0
[root at airbox /tmp]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0D:B9:00:41:0C
           inet addr:192.168.0.77  Bcast:192.168.0.255  Mask:255.255.255.0
           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:797 errors:0 dropped:0 overruns:0 frame:0
           TX packets:165 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:336111 (328.2 KiB)  TX bytes:11216 (10.9 KiB)
           Interrupt:10 Base address:0xd000

lo        Link encap:Local Loopback
           inet addr:127.0.0.1  Mask:255.0.0.0
           UP LOOPBACK RUNNING  MTU:16436  Metric:1
           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:0
           RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

--------

Well I also tried loading the firmware using prism2_srec without any 
luck :( I receive and IOCTL error.

That's all I think, any of you guys have an idea of what could be wrong?

Thanx a lot in advance for your time.

Best,

nettie





More information about the HostAP mailing list