Hostap ok , AP ok , but no ping

Sophal Sun ssun at firstream.net
Thu Apr 22 03:36:41 EDT 2004


Konstantin , Alberto

Thanks a lot for your support

a)
My iptables rules ( very basic )

***********************
#!/bin/sh
  iptables -t nat -F

  iptables -A FORWARD -i wlan0 -o eth0 -m state --state 
ESTABLISHED,RELATED -j $

  iptables -A FORWARD -i eth0 -o wlan0 -j ACCEPT
  iptables -A FORWARD -j LOG
  iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE
************************

b)
yes my client system get IP from the Wifi hostap box

the syslog :

Apr 21 14:39:09 grav dhcpd: DHCPDISCOVER from 00:03:2f:00:50:cc 
(HP-14739101069) via wlan0
Apr 21 14:39:09 grav dhcpd: DHCPOFFER on 192.168.20.230 to 
00:03:2f:00:50:cc (HP-14739101069) via wlan0
Apr 21 14:39:09 grav dhcpd: DHCPDISCOVER from 00:03:2f:00:50:cc 
(HP-14739101069) via wlan0
Apr 21 14:39:09 grav dhcpd: DHCPOFFER on 192.168.20.230 to 
00:03:2f:00:50:cc (HP-14739101069) via wlan0
Apr 21 14:39:09 grav dhcpd: DHCPREQUEST for 192.168.20.230 
(192.168.20.213) from 00:03:2f:00:50:cc (HP-14739101069) via wlan0
Apr 21 14:39:09 grav dhcpd: DHCPACK on 192.168.20.230 to 
00:03:2f:00:50:cc (HP-14739101069) via wlan0
Apr 21 14:39:09 grav dhcpd: DHCPREQUEST for 192.168.20.230 
(192.168.20.213) from 00:03:2f:00:50:cc (HP-14739101069) via wlan0
Apr 21 14:39:09 grav dhcpd: DHCPACK on 192.168.20.230 to 
00:03:2f:00:50:cc (HP-14739101069) via wlan0
********************************************************************************************

c)
No I didn't run tcdump on wlan0
In fact I don't know wich exact command to use with tcpdump



Sophal



Konstantin Klubnichkin a écrit :

>Hello Sophal,
>
>Thursday, April 22, 2004, 11:17:04 AM, you wrote:
>
>SS> No clue about my problem ?
>SS> May be do you need more information
>Actually yep, we need more info.
>
>1. How iptables are configured?
>2. Does your DHCP server really sends ACKS? Does your windows box
>gets IP?
>3. Did you try to run tcpdump on wlan0?
>
>
>
>  
>
>>>Hello All .
>>>
>>>I finally success to install Hostap with a Netgear PCI MA311 .
>>>
>>>Driver load perfect and wlan0 is up
>>>
>>>I installed dhcp and iptables on this box ,so my AP can distribute IP .
>>>
>>>On a Windows client the wifi card see the AP and the AP distribute one
>>>ip of the range define by my Dhcp daemon .
>>>
>>>But even all network configuration is ok according to the DHCPACK , I
>>>can not ping the AP from the Windows client .
>>>
>>>
>>>
>>>
>>>_______________________________________________
>>>HostAP mailing list
>>>HostAP at shmoo.com
>>>http://lists.shmoo.com/mailman/listinfo/hostap
>>>
>>>      
>>>
>
>
>
>SS> _______________________________________________
>SS> HostAP mailing list
>SS> HostAP at shmoo.com
>SS> http://lists.shmoo.com/mailman/listinfo/hostap
>
>
>SS> !DSPAM:408771dc74968551019270!
>
>
>
>  
>





More information about the HostAP mailing list