Problems with latest CVS

Michael Guntsche mike at it-loops.com
Sat Nov 29 12:42:47 EST 2003


Hello list,

I recently upgraded from a rather old but stable CVS checkout to the
latest version.
Now I have to problems:

1.) Since we now have a master netdev (wifi#). The debian pcmcia-cs
package has problems configuring the card properly.

Instead if calling "ifup wlan0" and then "pump wlan0" it now calls
"ifup wifi0" and then "pump wifi0" which obviously fails.
I know that this is not really a hostap related problem, but how can I
fix my startup scripts properly?


The second problem I have is far more serious, at least for me ;)

In earlier versions I could remove the card ( or call cardctl eject)
whenever I wanted. Now I have to bring down wlan0 first (ifconfig wlan0
down), else I get error messages after removing it and an oops during
the reinsertion of the card.

Error messages after removing the card.

hostap_cs: CS_EVENT_CARD_REMOVAL
wifi0: Interrupt, but dev not OK
hostap_cs: release postponed, 'wifi0' still open
wifi0: card already removed or not configured during shutdown
hostap_cs: detach postponed, 'wifi0' still locked
hostap_cs: release postponed, 'wifi0' still open
wifi0: hfa384x_cmd_issue: cmd reg was busy for 5000 usec
wifi0: hfa384x_cmd_issue - timeout - reg=0xffff
wifi0: hfa384x_cmd: entry still in list? (entry=de539b80, type=0,
res=-1)
wifi0: hfa384x_cmd: interrupted; err=-110
wifi0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd51,
len=6)
<repeating>

I have to re-boot the notebook to get a working card again.

Right now Im trying to find a fix for the first problem, but I can't to
anything about the second. Any help is appreciated.

System:
Acer Notebook
Linux kernel: 2.4.2[23]
Netgear MA401 PCMCIA wireless card


Thanks in advance,
Michael



More information about the HostAP mailing list