Hostap Crash

Nikolaos Kefalas nkef at freemail.gr
Sun Nov 23 04:59:38 EST 2003


I am running Redhat 9 with kernel 2.4.22 , 2.4.20-8 redhats default kernel .
A motherboard with 440BX chipset and a celeron 333 .
I tried the versions of hostap 0.04 , 0.11 , 0.12 .

My Card is an engenius .

Socket 0:
  product info: "INTERSIL", "HFA384x/IEEE", "Version 01.02", ""
  manfid: 0x0156, 0x0002
  function: 6 (network)

And i am using a pci2pcmcia card :
00:0f.0 CardBus bridge: Ricoh Co Ltd RL5c475 (rev 80)

I compiled hostap using make pccard and configured redhat scripts for it
DEVICE=wlan0
ONBOOT=yes
IPADDR=10.143.2.1
NETMASK=255.255.255.224
GATEWAY=
TYPE=Wireless
USERCTL=no
NETWORK=10.143.2.0
BROADCAST=10.143.2.31
PEERDNS=no
ESSID=PWN_Pyrap
MODE=Master
CHANNEL=1
RATE=11Mb/s

I configured it for AP mode .

After a while the clients get disconected and when i am try to pass a 
command with iwconfig it does not respone
wlan0: hfa384x_cmd: entry still in list? (entry=c1faece0, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c1faece0, 
type=0, cmd=0x0002, param0=0x0000, EVSTAT=0000                 INTEN=e09f)
wlan0: reset port failed to disable port

or the errors

iwconfig wlan0 essid PWN_pyrap
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; Invalid argument.

wlan0: updating basic rate set automatically to match with the new 
supported rate set
ip_tables: (C) 2000-2002 Netfilter core team
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16)
wlan0: 00:02:6f:05:52:c1 auth_cb - STA authenticated
wlan0: 00:02:6f:05:52:c1 assoc_cb - STA associated
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
Scan result translation succeeded (length=36)
wlan0: hfa384x_cmd: entry still in list? (entry=c1dc14e0, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c1dc14e0, 
type=0, cmd=0x0002, param0=0x0000, EVSTAT=0000 INTEN=e09f)
wlan0: reset port failed to disable port
NETDEV WATCHDOG: wlan0: transmit timed out
wlan0 Tx timed out! Resetting card
wlan0: CMD=8a32 EVSTAT=0000 OFFSET0=0000 OFFSET1=0000 SWSUPPORT0=8a32
wlan0: scheduled card reset
hostap_cs: wlan0: resetting card
prism2_pccard_cor_sreset: original COR 41
wlan0: removed pending cmd_queue entry (type=1, cmd=0x0011, param0=0xf100)
wlan0: removed pending cmd_queue entry (type=1, cmd=0x0011, param0=0xf100)
wlan0: removed pending cmd_queue entry (type=1, cmd=0x010b, param0=0x018e)
prism2_hw_init: initialized in 100 ms
prism2_tx_timeout: wake up queue
wlan0: driver bug - prism2_transmit() called when previous TX was pending
wlan0: prism2_tx - to BAP0 failed
wlan0: scheduled card reset
hostap_cs: wlan0: resetting card
prism2_pccard_cor_sreset: original COR 41
prism2_hw_init: initialized in 110 m

I can not find what is wrong .
Thank you for your help

Nikolaos Kefalas




More information about the HostAP mailing list