Genesis Mode

Dustin Marquess jailbird at alcatraz.fdf.net
Wed Nov 5 10:16:16 EST 2003


Jouni,

I just wanted to say thanks for your help, and thanks for your work on
HostAP.  It's a great piece of work, and you're really awsome for all
of the work that you do, both in the code and on this list.

-Dustin

Jouni Malinen <jkmaline at cc.hut.fi> wrote:
> On Tue, Nov 04, 2003 at 09:13:12PM -0600, Dustin Marquess wrote:
> 
> > wifi0: trying to read PDA from 0x007f0000: OK
> 
> That's interesting.. Either the card is at least semi-alive and provides
> working Aux port access or it happened to read some random data that
> fooled the driver to believe that the PDA was valid.. I haven't
> implemented CRC-16 checksum verification for this, so this may indeed be
> just random data having 0 followed by 2 in a suitable place.
> 
> Anyway, if the Aux port is actually working, one could, in theory at
> least, change the card RAM and maybe even get it running something
> useful. However, this would probably be quite difficult without quite
> thorough knowledge of the card internals (which are of course not
> documented in anything that would be publicly available).
> 
> > Could not get RID for component NIC
> 
> OK. PRI was not initialized correctly or STA firmware was started but
> horribly corrupted..
> 
> > hostap_cs: Initialization failed
> > Unable to handle kernel NULL pointer dereference at virtual address 00000024
> 
> > Not sure why cardmgr freaks the kernel out, but I'm not too worried.
> 
> I haven't tested the no_primary=1 code with hostap_cs. Having NIC ID
> read failing with hostap_pci did not crash the driver, but it is quite
> possible that hostap_cs does not handle it so well (probably some
> variables were not initialized, etc.). I would either need to get
> ksymoops-resolved dump of the error message. I'm not too worried about
> it either, but it should be fixed at some point, anyway.
> 
> > I tried prism2_srec with the -r option and then with the -g option,
> > both errored out:
> 
> Genesis mode is most probably not going to work with hfa3841-based card.
> Having the Aux port access available might indicate something, but
> getting the card really started after downloading suitable code into its
> RAM might prove to be quite difficult.
> 
> > It looks like it's trying to work, but dies.  Should I take a lucky
> > guess that the PRI firmware is hosed and I need to get the card into
> > Genesis mode?
> 
> It sure looks like the PRI firmware is not running properly.
> 
> > If that's the case, I might be crazy enough to try and rip the PCMCIA
> > card apart and try to fix it before I spend the money for a new card.
> > What pin on the hfa384x do I need to apply voltage?
> 
> There was some discussion about this in April.. See Pavel's email for
> details:
> http://lists.shmoo.com/pipermail/hostap/2003-April/002446.html



More information about the HostAP mailing list