hostap_cs unresolved symbols ver 0.0.3?

Bob Beers bbeers at
Thu May 22 13:34:28 EDT 2003

Hi list,

I have seen other messages about unresolved symbols,
but not my particular experience.  I've been using the
hostap_pci (and tested _plx and _pc) 2002-10-12 for some 
time, but recently figured I'd jump to the current 0.0.3.  

But here's where it gets weird ...

I am using 2.4.20 kernel (no modversions) with freeswan and 
diskonchip patches, I have stand-alone pcmcia-cs-3.2.4.  
So, I set PCMCIA_PATH=/usr/src/pcmcia-cs-3.2.4 in the 
Makefile and ran make pccard.  I copied the hostap*.o
files into my /lib/modules/.../pcmcia directory and ran
depmod -a, which returned no errors.  But when I run
/etc/rc.d/rc.pcmcia restart, the hostap_cs module does
not load.  If I attempt to load the module manually I get 

bash-2.05# modprobe hostap_cs
/lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o: unresolved symbol hostap_set_multicast_list_queue
/lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o: unresolved symbol hostap_update_sta_ps
/lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o: unresolved symbol hostap_set_hostapd
/lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o: unresolved symbol hostap_add_wds_link
/lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o: unresolved symbol hostap_info_init
/lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o: unresolved symbol hostap_80211_get_hdrlen
/lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o: unresolved symbol hostap_update_rx_stats
/lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o: unresolved symbol hostap_info_process
/lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o: insmod /lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o failed
/lib/modules/2.4.20/kernel/drivers/pcmcia/hostap_cs.o: insmod hostap_cs failed

dmesg has this line:

hostap_crypt: registered algorithm 'NULL'

I have not tried the _pci 0.0.3 yet.  Thanks for any help,


Bob Beers
Edge Access, Inc.

More information about the HostAP mailing list