hostap crash

Litin litinoveweedle at quick.cz
Fri May 16 20:17:25 EDT 2003


HI,
maybe I have same problem, please can you test if card hang up due to packet
(probably beacon frame) receiving? The simpliest way could be, if you using
external antena to remove it. Or just disable your Wlan infrastructure to
not be transmiting.

My problem looked same like your one until I've done this - Now module is
properly loaded, Wlan0 interface is in system, I can configure it by
Wireless Extensions - iwconfig, but when I connect antenna to my card
systems hang with kernel panic message.

-----------------------------------------------
Also similar problem can be founded in message archives:

Hello,
HAs anybody seen this problem before ?
The  hostap_pci driver seems to hand my linux box with
a Linksys WMP11 PCI-based prism2 card on a pentium 90
system.
I am using the latest debian unstable kernel
2.4.20-1-386 image. I compiled the hostap-sources both
from the latest debian source package as well as from
the latest cvs snapshot. In both cases I get the same
result:
The modules build without complaints and install
seemingly properly.
I can load hostap_crypt.o and hostap.o without
problems.
BUt The linux box comes to a complete freeze when I
try to modprobe the pci-specific hostap_pci.o ... ???

The only thing I get in console messages  before the
freeze is that It says it:
 detected a Prism2.5 card wlan0 on Irq12 at PCI
address 00.0a
 ... and then nothing. ... complete freeze including
numlock and Kb and TCP stack.
I know that my linksys WMP11 card 's hardware works ,
and that I have no PCI conflicts , because I can use
this  card with the linux-wlan-ng drivers ,  also
installed on the system.
In fact , with linux-wlan-ng and  kismet I can scan my
other (laptop) system's DWL-650 card 's presence from
this box and establish ad-Hoc connection..
Any help would be appreciated .
I have no idea what firmware the card is running. Is
there any way I can get some linux util to show me the
firmware version on a WMP11 card ?
Is there any way to debug this driver while modprobe
tries to install it that woudl dump to screen before
syslog ? Syslog doesn't show anything because system
hangs first.
-----------------------------------------------


Any suggestions?


-----Original Message-----
From: hostap-admin at shmoo.com [mailto:hostap-admin at shmoo.com]On Behalf Of
Bitlov
Sent: Saturday, May 17, 2003 12:01 AM
To: hostap at shmoo.com
Subject: hostap crash


Hi,
My computer hang when i insert the module hostap_plx.
I use a mini-itx EPIAM 933Mhz with debian and with a Belkin PCI->PCMCIA
adapter and a Prism2 (Ovislink). I have tried with both version 0.0.1 and
0.0.2. I use the kernel 2.4.20-1-386.
I have the messages :
PLX9052 PCI/PCMCIA adapter: mem=0xde003000, plx_io=0xe000, irq=10,
pccard_io=0xe400
hostap_plx: Registered netdevice wlan0
and then cannot do anything else than a reset....
I don't have problem with the orinoco_plx driver.

Can somebody help me?
Thanks
Bitlov
_____________________________________________________________________
Envie de discuter en "live" avec vos amis ? Tilicharger MSN Messenger
http://www.ifrance.com/_reloc/m la 1hre messagerie instantanie de France

_______________________________________________
HostAP mailing list
HostAP at shmoo.com
http://lists.shmoo.com/mailman/listinfo/hostap





More information about the HostAP mailing list