modprobe fails

Thomas Schreiner thomas at tschreiner.org
Thu May 15 07:02:11 EDT 2003


Hello all,
I finally got my Engenius card EL-2511CD PLUS (which is reported to use 
the Prism2.5 chipset) and a Ricoh PCI-PCMCIA bridge. Compiling and 
installing of hostap-0.0.2 works like a charm, but modprobe fails. The 
Kernel I use is 2.4.18 without Wireless Hamradio.
You might need the output of modprobe, lspci -vv and dmesg, it is 
included at the end.
Do you have any hints where my mistake is hidden? Do I actually have to 
use hostap_plx for Ricoh bridges?

Thank you very much, it would be very nice if you could help me.

Thomas

# modprobe hostap_plx
/lib/modules/2.4.18/net/hostap_plx.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, 
including invalid IO or IRQ parameters
/lib/modules/2.4.18/net/hostap_plx.o: insmod 
/lib/modules/2.4.18/net/hostap_plx.o failed
/lib/modules/2.4.18/net/hostap_plx.o: insmod hostap_plx failed

# lspci -vv
[snipped known hardware]
00:01.0 PCI bridge: Intel Corp. 440BX/ZX - 82443BX/ZX AGP bridge (rev 
03) (prog-if 00 [Normal decode])
         Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV+ VGASnoop- 
ParErr- Stepping- SERR- FastB2B-
         Status: Cap- 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium 
 >TAbort- <TAbort- <MAbort- >SERR- <PERR-
         Latency: 64
         Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
         I/O behind bridge: 0000e000-0000efff
         Memory behind bridge: fe900000-fe9fffff
         Prefetchable memory behind bridge: f7000000-f7ffffff
         BridgeCtl: Parity- SERR- NoISA+ VGA+ MAbort- >Reset- FastB2B+

00:07.3 Bridge: Intel Corp. 82371AB PIIX4 ACPI (rev 02)
         Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- 
ParErr- Stepping- SERR- FastB2B-
         Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium 
 >TAbort- <TAbort- <MAbort- >SERR- <PERR-
         Interrupt: pin ? routed to IRQ 9

00:10.0 CardBus bridge: Ricoh Co Ltd RL5c475 (rev 80)
         Subsystem: CARRY Computer ENG. CO Ltd: Unknown device 0101
         Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- 
ParErr- Stepping- SERR- FastB2B-
         Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium 
 >TAbort- <TAbort- <MAbort- >SERR- <PERR-
         Interrupt: pin A routed to IRQ 11
         Region 0: Memory at 10000000 (32-bit, non-prefetchable) 
[disabled] [size=4K]
         Bus: primary=00, secondary=02, subordinate=05, sec-latency=0
         I/O window 0: 00000000-00000003 [disabled]
         I/O window 1: 00000000-00000003 [disabled]
         BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset- 16bInt- 
PostWrite+
         16-bit legacy interface ports at 0001

# dmesg
Linux version 2.4.18 (root at airbase) (gcc version 2.95.4 20011002 (Debian 
prerelease)) #3 SMP Thu May 15 11:47:41 CEST 2003
BIOS-provided physical RAM map:
  BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
  BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
  BIOS-e820: 00000000000e1d6a - 00000000000ec0ba (reserved)
  BIOS-e820: 00000000000f7ccb - 0000000000100000 (reserved)
  BIOS-e820: 0000000000100000 - 0000000008000000 (usable)
  BIOS-e820: 00000000fec00000 - 00000000fed00000 (reserved)
  BIOS-e820: 00000000fee00000 - 00000000fef00000 (reserved)
  BIOS-e820: 00000000ffff7ccb - 0000000100000000 (reserved)
On node 0 totalpages: 32768
zone(0): 4096 pages.
zone(1): 28672 pages.
zone(2): 0 pages.
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Kernel command line: auto BOOT_IMAGE=Linux ro root=305
Initializing CPU#0
Detected 347.672 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 693.04 BogoMIPS
Memory: 126572k/131072k available (1097k kernel code, 4112k reserved, 
334k data, 216k init, 0k highmem)
Dentry-cache hash table entries: 16384 (order: 5, 131072 bytes)
Inode-cache hash table entries: 8192 (order: 4, 65536 bytes)
Mount-cache hash table entries: 2048 (order: 2, 16384 bytes)
Buffer-cache hash table entries: 8192 (order: 3, 32768 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
CPU: Before vendor init, caps: 0183fbff 00000000 00000000, vendor = 0
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
CPU: After vendor init, caps: 0183fbff 00000000 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: 0183fbff 00000000 00000000 00000000
CPU:             Common caps: 0183fbff 00000000 00000000 00000000
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
CPU: Before vendor init, caps: 0183fbff 00000000 00000000, vendor = 0
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
CPU: After vendor init, caps: 0183fbff 00000000 00000000 00000000
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: 0183fbff 00000000 00000000 00000000
CPU:             Common caps: 0183fbff 00000000 00000000 00000000
CPU0: Intel Pentium II (Deschutes) stepping 02
per-CPU timeslice cutoff: 1463.42 usecs.
SMP motherboard not detected.
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 347.6749 MHz.
..... host bus clock speed is 99.3355 MHz.
cpu: 0, clocks: 993355, slice: 496677
CPU0<T0:993344,T1:496656,D:11,S:496677,C:993355>
Waiting on wait_init_idle (map = 0x0)
All processors have done init_idle
PCI: PCI BIOS revision 2.10 entry at 0xfd933, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router PIIX [8086/7110] at 00:07.0
PCI: Found IRQ 11 for device 00:10.0
PCI: Sharing IRQ 11 with 00:08.0
Limiting direct PCI/PCI transfers.
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
tbxfroot-0067 [02] Acpi_find_root_pointer: RSDP structure not found
ACPI: System description tables not found
  tbxface-0068: *** Error: Acpi_load_tables: Could not get RSDP, AE_ERROR
  tbxface-0116: *** Error: Acpi_load_tables: Could not load tables: AE_ERROR
ACPI: System description table load failed
  utalloc-0494 [03] Ut_dump_allocations   : No outstanding allocations.
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ 
SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
block: 128 slots per queue, batch=32
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
     ide0: BM-DMA at 0xfcb0-0xfcb7, BIOS settings: hda:DMA, hdb:pio
     ide1: BM-DMA at 0xfcb8-0xfcbf, BIOS settings: hdc:DMA, hdd:pio
hda: ST34323A, ATA DISK drive
hdc: NEC CD-ROM DRIVE:282, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 8421840 sectors (4312 MB) w/128KiB Cache, CHS=524/255/63, UDMA(33)
hdc: ATAPI 32X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
Partition check:
  hda: hda1 hda2 < hda5 hda6 hda7 hda8 >
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
eepro100.c:v1.09j-t 9/29/99 Donald Becker 
http://www.scyld.com/network/eepro100.html
eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin 
<saw at saw.sw.com.sg> and others
PCI: Found IRQ 11 for device 00:08.0
PCI: Sharing IRQ 11 with 00:10.0
eth0: Intel Corp. 82557 [Ethernet Pro 100], 00:00:0E:9C:6B:EF, IRQ 11.
   Receiver lock-up bug exists -- enabling work-around.
   Board assembly 000000-000, Physical connectors present: RJ45
   Primary interface chip i82555 PHY #1.
   General self-test: passed.
   Serial sub-system self-test: passed.
   Internal registers self-test: passed.
   ROM checksum self-test: passed (0x24c9f043).
   Receiver lock-up workaround activated.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 8192 bind 8192)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 216k freed
Adding Swap: 248968k swap-space (priority -1)
hostap_crypt: registered algorithm 'NULL'
hostap_plx: 0.0.2 - 2003-05-03 (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_plx: No devices found, driver not installed.
hostap_crypt: unregistered algorithm 'NULL' (deinit)




More information about the HostAP mailing list