Fwd: iwconfig failures

Jouni Malinen jkmaline at cc.hut.fi
Sat May 10 20:14:09 EDT 2003


On Sat, May 10, 2003 at 01:38:37PM -0700, larry.leblanc at shaw.ca wrote:

>  - I've tried hostap-2002-10-12 and hostap-0.0.1 with no luck. I haven't tried hostap-0.0.2.

Please do try v0.0.2 first.. I fixed a race condition in get/set RID
operations and this fix could be enough to also fix the issue you have
seen. I'll take a closer look if the same issue is still present in
v0.0.2. 

> wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=0)
> wlan0: hfa384x_cmd: command was not completed (res=0, entry=c10fdf50, type=0, cmd=0x0021, param0=0xfd20)
> wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd20, len=8)

This looks like something is confusing the hardware and all commands are
not completed. The race I mentioned could cause such problems since it
ended up doing two BAP operations at the same time..

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list