iwconfig failures

larry.leblanc at shaw.ca larry.leblanc at shaw.ca
Sat May 10 15:54:35 EDT 2003


Hello,

I have been using hostap (2002-10-12) for an access point application on a PCI system with a Linksys WPC11-CA version 3 card. I am now attempting to port everything to a PC-104 (ISA bus) system and I'm running into trouble. The card is recognized OK but any attempts to configure parameters on it with iwconfig fail with:
  Error for wireless request "Set ESSID" (8B1A) :
      SET failed on device wlan0 ; Invalid argument.

An attempt to set the mode to Master (iwconfig wlan0 mode Master) but that is the default setting; attempts to change it to something else, i.e. Managed, result in:
  Error for wireless request "Set Mode" (8B06) :
      SET failed on device wlan0 ; Operation not supported

The exact same card works OK on my PCI system so I'm thinking there is something wrong with the ISA-PCMCIA adapter. I am using the i82365 driver loaded with "modprobe i82365 do_scan=0 poll_interval=100". The do_scan and poll_interval options were in the default configuration from the equipment manufacturer; could they be causing problems? I've tried leaving them out but then the modprobe hangs indefinitely and the system locks up. I haven't tried leaving out just one of them, I guess I'll do that next.

Other considerations:
- kernel is 2.4.20
- distribution is Slackware 9.0
- my working PCI system uses wireless extensions version 13, the PC-104 system one uses 14. I haven't tried version 15.
 - I've tried hostap-2002-10-12 and hostap-0.0.1 with no luck. I haven't tried hostap-0.0.2.

I'm going to continue going through all the configuration options (regress to wireless extensions 13, then try the new version 15, try hostap-0.0.2) but if someone can short-circuit the process that would be helpful.

BTW, below is the relevant output of dmesg. Note that everything seems fine (as far as I know) until we get past/into prism2_hw_init() and various "command was not completed" errors start showing up.

Thanks,

Larry LeBlanc

dmesg output:
-----------------------
Linux Kernel Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
Intel PCIC probe: 
  Vadem VG-468 ISA-to-PCMCIA at port 0x3e0 ofs 0x00, 2 sockets
    host opts [0]: none
    host opts [1]: none
    ISA irqs (default) = 3,4,5,7,9,10,11,12,15 polling interval = 1000 ms
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x218-0x21f 0x320-0x327 0x378-0x37f 0x480-0x48f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0x0d0000-0x0dffff: excluding 0xd0000-0xd5fff
cs: memory probe 0x0c0000-0x0cffff: excluding 0xc0000-0xcbfff
hostap_crypt: registered algorithm 'NULL'
hostap_cs: hostap_cs.c 0.0.0 2002-10-12 (SSH Communications Security Corp, Jouni Malinen)
hostap_cs: (c) Jouni Malinen <jkmaline at cc.hut.fi>
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
prism2_config()
hostap_cs: setting Vcc=50 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f
divert: allocating divert_blk for wlan0
hostap_cs: Registered netdevice wlan0
prism2_hw_init()
prism2_hw_config: initialized in 25559 iterations
wlan0: NIC: id=0x801b v1.0.0
wlan0: PRI: id=0x15 v1.1.0
wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c10fdf50, type=0, cmd=0x0021, param0=0xfd20)
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd20, len=8)
Could not get RID for component STA
wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c10fdf50, type=0, cmd=0x0021, param0=0xfd20)
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd20, len=8)
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8021
wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fc01, len=6)
wlan0: could not get own MAC address
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=-110, rid=fc00, len=2)
wlan0: Port type setting to 6 failed
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: MAC port 0 enabling failed





More information about the HostAP mailing list