problems running hostapd on RedHat9

Douglas Held wireless at douglasheld.net
Wed May 7 03:57:20 EDT 2003


Hello,

I have downloaded hostap-0.0.2 and have tried to install the hostap_plx.0 module.

I just upgraded RedHat9 on top of RedHat 7.2, which may not have been a good idea.  In any case, my current kernel-source tree is /usr/src/linux-2.4.20-8 which is soft linked to /usr/src/linux .

/usr/src/linux/.config wasn't found, so I wen to /usr/src and ran 'make oldconfig' and one appeared.  I must say I don't know what this is, but hostap_plx appeared to compile OK after that.

'insmod hostap_plx.o' didn't find the module so I added the following entry to /etc/modules.conf :
	PATH=/lib/modules/2.4.20-8/net
	alias wlan0 hostap_plx

Finally, I can load the module and create a little init.d script:
#!/bin/bash
case "$1" in
start)
        insmod hostap_crypt
        insmod hostap_crypt_wep
        insmod hostap
        insmod hostap_plx
        /usr/local/bin/hostapd -Bdd /etc/hostapd.conf
        ;;
stop)
        ifconfig wlan0 down
        rmmod hostap_plx
        rmmod hostap
        rmmod hostap_crypt_wep
        rmmod hostap_crypt
        ;;
esac

...and 

[root at router init.d]# hostapd -dd /etc/hostapd.conf
Configuration file: /etc/hostapd.conf
ioctl(SIOCGIFINDEX): No such device
ioctl[SIOCGIFFLAGS]: No such device


Questions:
1. Is there something I've done above that is wrong?
2. Do I need to patch this kernel version (2.4.20-8)?

--Doug




More information about the HostAP mailing list