HostAP and Linux Kernel 2.2

Jouni Malinen jkmaline at cc.hut.fi
Fri Mar 28 23:10:53 EST 2003


On Wed, Mar 26, 2003 at 09:25:44AM +0100, Dirk Molitor wrote:

> I have a server running Linux Kernel 2.2 and want to use this server as an HostAP.
> I have on free PCI slot. The server can't be upgraded to Kernel 2.4.
> As far as I understand, I can't use PCI and PLX cards because they need Kernel 2.4.
> 
> What possbilities do I have? 

1) upgrading to Linux 2.4.x
2) backporting Host AP PCI/PLX driver to Linux 2.2.x yourself

I haven't implemented support for PCI code in Linux 2.2.x since it is
quite different from the one in 2.4.x. In addition, I do not have any
plans on doing this in the future.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list