HostAP on Debian Woody: NO WLAN INTERFACE CREATED :(

Martin Schrodt spheenik at gmx.net
Thu Jun 12 09:13:02 EDT 2003


Hi List!

I am desperately trying to get a LG LW1100P Board Revision 2.0 PCI card to work with HostAP. It consists of a TI 1211 PCI-to-Cardbus Controller and a Prism2 chipset. I already have the PCMCIA part working, so doing a "cardctl ident" shows a "LG", "11Mbps Wireless LAN PCI Card" "Version 1.02" with manfid 0x0156, 0x0002.
I succeeded in compiling the hostap_cs driver and the module loads without complaining. However, it doesnt create a wlan0 interface. The syslog only shows one line after inserting the module: 
"kernel: hostap_cs: 0.0.3 - 2003-05-18 (Jouni Malinen <jkmailine at cc.hut.fi>) The machine uses a self compiled kernel 2.4.18 from woody with WLAN extensions turned on (so /proc/net/wireless is there) Trying to issue any iwXXXXX command (for example "iwconfig wlan0 mode managed" results in "SET failed on device WLAN0 ; No such device") results in an error. Up to now, i have not managed to get any debugging information from hostap itself, "cardctl status" shows:

Socket 0
    3.3V 16-bit PC Card
    function 0: [ready] [bat low]

The  LED on the card lights as soon as i do "/etc/init.d/pcmcia start". I am running out of ideas for that one. Install a new kernel? I don't think so, because people from this mailing list have it working on 2.4.9 kernels.... I also tried to compile my own set of PCMCIA-CS modules (tried 3.1.33, 3.1.34, 3.2.4), then "cardctl ident" shows no card available. Currently i am using "yenta_socket", which detects the card.
I hope there is someone out there who can provide some help, at least in how i can talk hostap_cs into verbosing more....

Thx
Martin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20030612/d239d0ef/attachment.htm 


More information about the HostAP mailing list