hostap-0.0.3 + hostapd + 802.1x how to ???

Jouni Malinen jkmaline at cc.hut.fi
Sun Jun 8 22:39:13 EDT 2003


On Fri, May 30, 2003 at 12:20:32AM +0000, Haidong Xia wrote:

> 2. make, and run hostapd. I configured the hostapd.conf to point to my 
> Freeradius server

It would be easier to diagnose this if you sent your hostapd.conf..

> I tried to use a client to authenticate. I can watch 'EAPOL start ' frame 
> at the HostAP machine. But the client could receive the 'EAP request'.  It 
> seems hostapd tried to send it.

Which station did you use and which IEEE 802.1X supplicant? Please send
hostapd debug log (output from 'hostapd -dd hostapd.conf').

> I doubt that the 'EAP request' frame was not sent out from the access 
> point. Does anybody have such experience, and how I can fix it?

Do you have a wireless sniffer that you could use to verify whether it
was sent or not? You can also capture packets from wlan0ap interface in
the AP. That should at least show whether hostapd is trying to send that
frame.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list