hostap in master mode and firmware 1.6.3

Martin Whitlock martin.whitlock at possio.com
Tue Jan 28 11:27:09 EST 2003


First of all I think that you should use PRI 1.1.1 together with STA 1.6.3.
But still, it doesn't seem to work in HostAP mode. No stations can
associate. I have verified with a spectrum analyzer that some kind of beacon
is being sent periodically, and the transmitted frequency responds when I
change channel with iwconfig. I suppose I should be able to capture the
frames by putting another card in monitor mode, but I actually don't know
exactly how to. Any hints? This is dmesg output from AP side:

********************************************
wlan0: RX status=0x0000 (port=0, type=0, fcserr=0) silence=10 signal=43
rate=10
rxflow=0; jiffies=97746
   FC=0x0080 (type=0:8) dur=0x0000 seq=0xb200 data_len=40
   A1=ff:ff:ff:ff:ff:ff A2=00:60:b3:6f:8b:56 A3=00:60:b3:6f:8b:56
A4=67:23:78:71
:74:aa
   dst=ff:ff:ff:ff:ff:ff src=00:50:ba:e7:75:67 len=40
wlan0: prism2_rx: dropped non-data frame (type=0x00, subtype=0x08)
wlan0: RX status=0x0000 (port=0, type=0, fcserr=0) silence=14 signal=21
rate=10
rxflow=0; jiffies=97747
   FC=0x0080 (type=0:8) dur=0x0000 seq=0xb850 data_len=37
   A1=ff:ff:ff:ff:ff:ff A2=00:05:4e:81:04:6a A3=00:05:4e:81:04:6a
A4=95:e3:ab:64
:6b:ac
   dst=ff:ff:ff:ff:ff:ff src=00:02:2d:27:4c:26 len=37
wlan0: prism2_rx: dropped non-data frame (type=0x00, subtype=0x08)
wlan0: RX status=0x0000 (port=0, type=0, fcserr=0) silence=12 signal=26
rate=10
rxflow=0; jiffies=97748
   FC=0x0080 (type=0:8) dur=0x0000 seq=0x94b0 data_len=35
   A1=ff:ff:ff:ff:ff:ff A2=00:05:4e:81:02:a9 A3=00:05:4e:81:02:a9
A4=d1:c7:d6:b0
:64:42
   dst=48:05:c2:a1:57:3a src=b0:46:9f:f6:b1:86 len=35
********************************************

Funny thing is that none of these MAC-addresses seem familiar to me. Exactly
what should these different address fields include?

BTW, new features in STA 1.6.3 seems to be RIDs for Enhanced Security, i.e.
hiding SSID in beacon and block responces to "ANY"-clients. "Frames to
stations in promiscous mode will now be ACKed", but I havn't verified that
yet. Otherwise it's mostly PS stuff.

/Martin





> -----Original Message-----
> From: hostap-admin at shmoo.com [mailto:hostap-admin at shmoo.com]On Behalf Of
> Jouni Malinen
> Sent: den 28 januari 2003 02:59
> To: hostap at shmoo.com
> Subject: Re: hostap in master mode and firmware 1.6.3
>
>
> On Mon, Jan 27, 2003 at 06:48:27PM +0200, Alexey wrote:
>
> > STA v1.6.3
> >
> > All work perfectly in Ad-hoc mode and in Managed mode with Lucent AP.
> > But we can't get it worked in Master mode. When we turn on
> Master mode nothing happened.
>
> I do not have v1.6.3 station firmware, so it is a bit difficult to guess
> what might have changed. It would be easier to debug any problems should
> I get the same version, and even more easier, if it would come with
> change log ;-).
>
> > if we turn on debug with prism2_param debug 3
> > we can see only such lines in log:
> >
> > kernel: wlan0: TX status=0x0000 retry_count=0 tx_rate=0
> tx_control=0x000c; jiffies=3047063
> > kernel:    FC=0x0008 (type=2:0) dur=0x0000 seq=0x0000 data_len=36
> > kernel:    A1=ff:ff:ff:ff:ff:ff A2=00:03:2f:00:99:e2
> A3=02:03:9a:ed:99:e2 A4=00:00:00:00:00:00
> > kernel:    dst=ff:ff:ff:ff:ff:ff src=00:03:2f:00:99:e2 len=36
>
> Is 02:03:9a:ed:99:e2 the MAC address of the card? If not, this looks
> odd. If it is, this might be OK.
>
> > Does it possible to run such type of card in Master mode? Any hints?
>
> Hard to say without debugging this a bit more. Could you please send me
> output of "utils/hostap_diag -ru wlan0"? If that looks OK, I would
> try to first check whether the card is sending beacon frames or not.
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>




More information about the HostAP mailing list