oddness/problem with hostap-2002-10-12

Georg C. F. Greve greve at gnu.org
Tue Jan 28 06:13:57 EST 2003


Hi,

I have been trying kernel 2.4.21-pre3 with hostap-2002-10-12 on Debian
with wireless-tools 25-2 (so v15 of the wireless extensions all
around).

The driver seems to load fine, but when I issue some iwconfig
commands, like

 iwconfig wlan0 essid "TEST"

I get a

 Error for wireless request "Set ESSID" (8B1A) :
     SET failed on device wlan0 ; Invalid argument.

although it in fact *does* work, at least

 iwconfig wlan0

gives me

 wlan0     IEEE 802.11-DS  ESSID:"TEST"  
           Mode:Master  Tx-Power:15 dBm   
           Encryption key:off
           Link Quality:0  Signal level:0  Noise level:0
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:0  Invalid misc:0   Missed beacon:0

(works the same with any other ESSID).


That seems odd and causes scripts to fail (obviously), so it is
somewhat annoying. 

I couldn't find any reference to this on the web, so I thought I'd ask
here.

Regards,
Georg


P.S. The card is a Avaya/Lucent Gold PRISM card.

P.P.S. Does anyone know a good "how to set up an AP" howto? I get
things working, sometimes it would be useful to read a little about
how it would be done best, though. But all I could find describes how
to set up the driver, but doesn't talk about the best
configurations...

-- 
Georg C. F. Greve                                       <greve at gnu.org>
Free Software Foundation Europe	                 (http://fsfeurope.org)
Brave GNU World	                           (http://brave-gnu-world.org)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 258 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20030128/344e4fe0/attachment.pgp 


More information about the HostAP mailing list