Struggling with Pheenet card

Jouni Malinen jkmaline at cc.hut.fi
Sun Jan 26 13:54:34 EST 2003


On Sun, Jan 26, 2003 at 07:35:49PM +0000, Harry Moyes wrote:

>   Pheenet WL-002 radio card.

I have never used such card, but I hostap_plx has been reported to work
with Pheecom WL-PCI, which has same PCI id as your card.

>   Bus  0, device  11, function  0:
>     Network controller: PCI device 15e8:0131 (National Datacomm Corp) (rev 1).
>       IRQ 15.
>       I/O at 0x5424 [0x5433].
>       I/O at 0x1000 [0x103f].

Could you please send a bit more detailed info about this device
('lspci -vvd 15e8:0131')?

> hostap_plx: (c) Jouni Malinen <jkmaline at cc.hut.fi>
> TMD7160 PCI/PCMCIA adapter: io=0x5424, irq=15, pccard_io=0x1000
> hostap_plx: Error setting COR (expected=0x45, was=0xff)

TMD7160 adapter was apparently found, but when the first control area
was written to (COR register), the following read from the same register
did not return the same value. I would assume that this indicates some
problems with I/O, but one could test ignoring this by commenting out
"goto fail;" line in the code snippet you quoted: 

>                 if (reg != (cor_index | COR_LEVLREQ | COR_ENABLE_FUNC)) {
>                         printk(KERN_ERR "%s: Error setting COR (expected="
>                                "0x%02x, was=0x%02x)\n", dev_info,
>                                cor_index | COR_LEVLREQ | COR_ENABLE_FUNC, 
> reg);
>                         goto fail;
>                 }


> Am I doing something obvious wrong..

No.

> Is this likely to be improved by moving to a current kernel and the CVS 
> version of hostap, or does this imply an incompatability between hostap and 
> this card?

At least Host AP code has not changed on that part, so updating it
should not produce any difference.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list