hostap and compaq wl-200

Craig Sanders cas at taz.net.au
Fri Jan 17 11:38:00 EST 2003


ok, i'm stumped.  i've tried three different versions of the hostap
drivers (2002.09.12, 2002.10.12, and the CVS tarball fetched about an
hour ago).  i get the same problem with them all.

kernel version is 2.4.20
wireless extensions patches v15 and v16 applied.  (same problem without the patches)
pcmcia-cs is 3.2.2  (i've also tried 3.1.33)
wireless tools v25
dist is debian (unstable, from my local mirror last updated about a week ago)


the hardware is an Intel BX motherboard with a  P2-233 and 128MB.  1
ethernet card, and 2 compaq WL200 wireless cards.  (i get the same
problem with only one card installed).


any clues or pointers in the right direction would be appreciated.


dmesg shows pcmcia-cs starts up OK:

Linux PCMCIA Card Services 3.2.2
  kernel build: 2.4.20 unknown
  options:  [pci] [cardbus] [apm]
Intel ISA/PCI/CardBus PCIC probe:
PCI: Found IRQ 11 for device 00:0d.0
PCI: Sharing IRQ 11 with 01:00.0
  Cirrus PD6729 rev 00 PCI-to-PCMCIA at slot 00:0d, port 0x1430
    host opts [0]: [ring] [1/5/0] [1/20/0]
    host opts [1]: [ring] [1/5/0] [1/20/0]
    ISA irqs (default) = 3,4,5,7,12 polling interval = 1000 ms
PCI: Found IRQ 10 for device 00:0e.0
  Cirrus PD6729 rev 00 PCI-to-PCMCIA at slot 00:0e, port 0x1434
    host opts [0]: [ring] [1/5/0] [1/20/0]
    host opts [1]: [ring] [1/5/0] [1/20/0]
    ISA irqs (default) = 3,4,5,7,12 polling interval = 1000 ms
cs: memory probe 0x0d0000-0x0dffff: clean.


the hostap driver loads ok. it recognises but fails to initialise the
cards.  looks like it can't get or set any config data from them.  

i suspect (but am far from sure) that it may be some IRQ weirdness.
note that pcmcia-cs above detects IRQs 11 and 10, while hostap_cs below
ends up using IRQs 3 and 5.    or this may be perfectly normal for these
pci-to-pcmcia adaptors.  dunno.


hostap_crypt: registered algorithm 'NULL'
hostap_cs: 0.0.0 CVS (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
prism2_config()
hostap_cs: setting Vcc=33 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
Config has no IRQ info, but trying to enable IRQ anyway..
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
cs: IO port probe 0x0100-0x04ff: excluding 0x378-0x37f 0x3c0-0x3df 0x4d0-0x4d7
cs: IO port probe 0x0380-0x03bf: clean.
cs: IO port probe 0x03e0-0x04cf: clean.
cs: IO port probe 0x04d8-0x04ff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0a00-0x0aff: clean.
cs: IO port probe 0x0c00-0x0cff: clean.
hostap_cs: index 0x01: Vcc 3.3, irq 3, io 0x0100-0x013f
hostap_cs: Registered netdevice wlan0
prism2_hw_init()
prism2_hw_config: initialized in 9168 iterations
wlan0: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c4074da0, type=0, cmd=0x0021, param0=0xfd0b)
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd0b, len=8)
Could not get RID for component NIC
wlan0: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c4074da0, type=0, cmd=0x0021, param0=0xfd02)
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd02, len=8)
Could not get RID for component PRI
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8021
wlan0: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd20, len=8)
Could not get RID for component STA
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8021
wlan0: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd20, len=8)
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8021
wlan0: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fc01, len=6)
wlan0: could not get own MAC address
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=-110, rid=fc00, len=2)
wlan0: Port type setting to 6 failed
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: MAC port 0 enabling failed


same thing for the wlan1 card.


hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
prism2_config()
hostap_cs: setting Vcc=33 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
Config has no IRQ info, but trying to enable IRQ anyway..
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: index 0x01: Vcc 3.3, irq 5, io 0x0140-0x017f
hostap_cs: Registered netdevice wlan1
prism2_hw_init()
prism2_hw_config: initialized in 9171 iterations
wlan1: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=0)
wlan1: hfa384x_cmd: command was not completed (res=0, entry=c4074da0, type=0, cmd=0x0021, param0=0xfd0b)
wlan1: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd0b, len=8)
Could not get RID for component NIC
wlan1: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=0)
wlan1: hfa384x_cmd: command was not completed (res=0, entry=c4074da0, type=0, cmd=0x0021, param0=0xfd02)
wlan1: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd02, len=8)
Could not get RID for component PRI
wlan1: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan1: hfa384x_cmd_issue - timeout - reg=0x8021
wlan1: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=-1)
wlan1: hfa384x_cmd: interrupted; err=-110
wlan1: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd20, len=8)
Could not get RID for component STA
wlan1: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan1: hfa384x_cmd_issue - timeout - reg=0x8021
wlan1: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=-1)
wlan1: hfa384x_cmd: interrupted; err=-110
wlan1: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd20, len=8)
wlan1: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan1: hfa384x_cmd_issue - timeout - reg=0x8021
wlan1: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=-1)
wlan1: hfa384x_cmd: interrupted; err=-110
wlan1: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fc01, len=6)
wlan1: could not get own MAC address
wlan1: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan1: hfa384x_cmd_issue - timeout - reg=0x8000
wlan1: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=-1)
wlan1: hfa384x_cmd: interrupted; err=-110
wlan1: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=-110, rid=fc00, len=2)
wlan1: Port type setting to 6 failed
wlan1: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan1: hfa384x_cmd_issue - timeout - reg=0x8000
wlan1: hfa384x_cmd: entry still in list? (entry=c4074da0, type=0, res=-1)
wlan1: hfa384x_cmd: interrupted; err=-110
wlan1: MAC port 0 enabling failed




not surprisingly, any attempt to use iwconfig results in the same
errors:

hanuman:~# iwconfig wlan0 essid foo 
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; Invalid argument.


...
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fc09, len=2)
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c74bb7a0, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c74bb7a0, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd48, len=2)
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c74bb7a0, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd43, len=6)
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c74bb760, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=-110, rid=fc02, len=34)




thanks for any help, suggestions, or ideas.


craig


-- 
craig sanders <cas at taz.net.au>

Fabricati Diem, PVNC.
 -- motto of the Ankh-Morpork City Watch



More information about the HostAP mailing list